[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20211208084732.23363-3-nicolinc@nvidia.com>
Date: Wed, 8 Dec 2021 00:47:28 -0800
From: Nicolin Chen <nicolinc@...dia.com>
To: <thierry.reding@...il.com>, <joro@...tes.org>, <will@...nel.org>
CC: <digetx@...il.com>, <vdumpa@...dia.com>, <jonathanh@...dia.com>,
<linux-tegra@...r.kernel.org>, <iommu@...ts.linux-foundation.org>,
<linux-kernel@...r.kernel.org>
Subject: [PATCH v7 2/6] iommu/tegra-smmu: Rename tegra_smmu_find_group to tegra_smmu_find_group_soc
The existing function tegra_smmu_find_group really finds group->soc
pointer, so naming it "find_group" might not be clear by looking at
it alone. This patch renames it to tegra_smmu_group_soc in order to
disambiguate the use of "group" in this driver.
Signed-off-by: Nicolin Chen <nicolinc@...dia.com>
---
drivers/iommu/tegra-smmu.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/iommu/tegra-smmu.c b/drivers/iommu/tegra-smmu.c
index f874ee2600e5..9e9f37e4894c 100644
--- a/drivers/iommu/tegra-smmu.c
+++ b/drivers/iommu/tegra-smmu.c
@@ -870,7 +870,7 @@ static struct iommu_device *tegra_smmu_probe_device(struct device *dev)
static void tegra_smmu_release_device(struct device *dev) {}
static const struct tegra_smmu_group_soc *
-tegra_smmu_find_group(struct tegra_smmu *smmu, unsigned int swgroup)
+tegra_smmu_find_group_soc(struct tegra_smmu *smmu, unsigned int swgroup)
{
unsigned int i, j;
@@ -902,7 +902,7 @@ static struct iommu_group *tegra_smmu_device_group(struct device *dev)
struct iommu_group *grp;
/* Find group_soc associating with swgroup */
- soc = tegra_smmu_find_group(smmu, swgroup);
+ soc = tegra_smmu_find_group_soc(smmu, swgroup);
mutex_lock(&smmu->lock);
--
2.17.1
Powered by blists - more mailing lists