lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sat, 18 Dec 2021 10:16:42 +0100
From:   Mauro Carvalho Chehab <mchehab@...nel.org>
To:     davidcomponentone@...il.com
Cc:     arnd@...db.de, hverkuil-cisco@...all.nl,
        laurent.pinchart@...asonboard.com, linux-media@...r.kernel.org,
        linux-kernel@...r.kernel.org, Yang Guang <yang.guang5@....com.cn>,
        Zeal Robot <zealci@....com.cn>
Subject: Re: [PATCH] media: saa7134: use swap() to make code cleaner

Em Sat, 18 Dec 2021 09:58:02 +0800
davidcomponentone@...il.com escreveu:

> From: Yang Guang <yang.guang5@....com.cn>
> 
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
> 
> Reported-by: Zeal Robot <zealci@....com.cn>
> Signed-off-by: David Yang <davidcomponentone@...il.com>
> Signed-off-by: Yang Guang <yang.guang5@....com.cn>
> ---
>  drivers/media/pci/saa7134/saa7134-video.c | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/media/pci/saa7134/saa7134-video.c b/drivers/media/pci/saa7134/saa7134-video.c
> index 374c8e1087de..6f4132058c35 100644
> --- a/drivers/media/pci/saa7134/saa7134-video.c
> +++ b/drivers/media/pci/saa7134/saa7134-video.c
> @@ -823,7 +823,7 @@ static int buffer_activate(struct saa7134_dev *dev,
>  {
>  	struct saa7134_dmaqueue *dmaq = buf->vb2.vb2_buf.vb2_queue->drv_priv;
>  	unsigned long base,control,bpl;
> -	unsigned long bpl_uv,lines_uv,base2,base3,tmp; /* planar */
> +	unsigned long bpl_uv, lines_uv, base2, base3; /* planar */
>  
>  	video_dbg("buffer_activate buf=%p\n", buf);
>  	buf->top_seen = 0;
> @@ -869,9 +869,7 @@ static int buffer_activate(struct saa7134_dev *dev,
>  		base2    = base + bpl * dev->height;
>  		base3    = base2 + bpl_uv * lines_uv;
>  		if (dev->fmt->uvswap) {
> -			tmp = base2;
> -			base2 = base3;
> -			base3 = tmp;
> +			swap(base2, base3);
>  		}

No need for {}

>  		video_dbg("uv: bpl=%ld lines=%ld base2/3=%ld/%ld\n",
>  			bpl_uv,lines_uv,base2,base3);



Thanks,
Mauro

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ