[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <YcBigHusYbH/CY7I@kroah.com>
Date: Mon, 20 Dec 2021 12:01:20 +0100
From: Greg KH <gregkh@...uxfoundation.org>
To: Sudeep Holla <sudeep.holla@....com>
Cc: stable@...r.kernel.org, linux-kernel@...r.kernel.org,
Pedro Batista <pedbap.g@...il.com>,
Cristian Marussi <cristian.marussi@....com>,
Arnd Bergmann <arnd@...db.de>
Subject: Re: [PATCH] [BACKPORT v4.9 - v4.19] firmware: arm_scpi: Fix string
overflow in SCPI genpd driver
On Fri, Dec 17, 2021 at 02:20:56PM +0000, Sudeep Holla wrote:
> commit 865ed67ab955428b9aa771d8b4f1e4fb7fd08945 upstream.
>
> Without the bound checks for scpi_pd->name, it could result in the buffer
> overflow when copying the SCPI device name from the corresponding device
> tree node as the name string is set at maximum size of 30.
>
> Let us fix it by using devm_kasprintf so that the string buffer is
> allocated dynamically.
>
> Fixes: 8bec4337ad40 ("firmware: scpi: add device power domain support using genpd")
> Reported-by: Pedro Batista <pedbap.g@...il.com>
> Signed-off-by: Sudeep Holla <sudeep.holla@....com>
> Cc: stable@...r.kernel.org #v4.9, v4.14, v4.19
> Cc: Cristian Marussi <cristian.marussi@....com>
> Link: https://lore.kernel.org/r/20211209120456.696879-1-sudeep.holla@arm.com
> Signed-off-by: Arnd Bergmann <arnd@...db.de>
> ---
> drivers/firmware/scpi_pm_domain.c | 10 +++++++---
> 1 file changed, 7 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/firmware/scpi_pm_domain.c b/drivers/firmware/scpi_pm_domain.c
> index f395dec27113..a6e62a793fbe 100644
> --- a/drivers/firmware/scpi_pm_domain.c
> +++ b/drivers/firmware/scpi_pm_domain.c
> @@ -27,7 +27,6 @@ struct scpi_pm_domain {
> struct generic_pm_domain genpd;
> struct scpi_ops *ops;
> u32 domain;
> - char name[30];
> };
>
> /*
> @@ -121,8 +120,13 @@ static int scpi_pm_domain_probe(struct platform_device *pdev)
>
> scpi_pd->domain = i;
> scpi_pd->ops = scpi_ops;
> - sprintf(scpi_pd->name, "%s.%d", np->name, i);
> - scpi_pd->genpd.name = scpi_pd->name;
> + scpi_pd->genpd.name = devm_kasprintf(dev, GFP_KERNEL,
> + "%s.%d", np->name, i);
> + if (!scpi_pd->genpd.name) {
> + dev_err(dev, "Failed to allocate genpd name:%s.%d\n",
> + np->name, i);
> + continue;
> + }
> scpi_pd->genpd.power_off = scpi_pd_power_off;
> scpi_pd->genpd.power_on = scpi_pd_power_on;
>
> --
> 2.25.1
>
Now queued up, thanks.
greg k-h
Powered by blists - more mailing lists