[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20211222130820.1754-8-thunder.leizhen@huawei.com>
Date: Wed, 22 Dec 2021 21:08:10 +0800
From: Zhen Lei <thunder.leizhen@...wei.com>
To: Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
<x86@...nel.org>, "H . Peter Anvin" <hpa@...or.com>,
<linux-kernel@...r.kernel.org>, Dave Young <dyoung@...hat.com>,
Baoquan He <bhe@...hat.com>, Vivek Goyal <vgoyal@...hat.com>,
Eric Biederman <ebiederm@...ssion.com>,
<kexec@...ts.infradead.org>,
Catalin Marinas <catalin.marinas@....com>,
"Will Deacon" <will@...nel.org>,
<linux-arm-kernel@...ts.infradead.org>,
Rob Herring <robh+dt@...nel.org>,
Frank Rowand <frowand.list@...il.com>,
<devicetree@...r.kernel.org>, Jonathan Corbet <corbet@....net>,
<linux-doc@...r.kernel.org>
CC: Zhen Lei <thunder.leizhen@...wei.com>,
Randy Dunlap <rdunlap@...radead.org>,
Feng Zhou <zhoufeng.zf@...edance.com>,
Kefeng Wang <wangkefeng.wang@...wei.com>,
Chen Zhou <dingguo.cz@...group.com>,
"John Donnelly" <John.p.donnelly@...cle.com>
Subject: [PATCH v18 07/17] x86/setup: Eliminate a magic number in reserve_crashkernel()
From: Chen Zhou <chenzhou10@...wei.com>
Replace '(1ULL << 32)' with CRASH_ADDR_LOW_MAX to improve readability,
they are equal.
Signed-off-by: Chen Zhou <chenzhou10@...wei.com>
Signed-off-by: Zhen Lei <thunder.leizhen@...wei.com>
---
arch/x86/kernel/setup.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
index 52aa925877ca787..abff57ffbe92884 100644
--- a/arch/x86/kernel/setup.c
+++ b/arch/x86/kernel/setup.c
@@ -523,7 +523,7 @@ static void __init reserve_crashkernel(void)
}
#ifdef CONFIG_X86_64
- if (crash_base >= (1ULL << 32)) {
+ if (crash_base >= CRASH_ADDR_LOW_MAX) {
/*
* Ensure that at least 256M extra low memory is allocated for
* DMA buffers and swiotlb, if low memory size is not specified.
--
2.25.1
Powered by blists - more mailing lists