[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YddS1dGYawOCqfVg@dt>
Date: Thu, 6 Jan 2022 14:36:37 -0600
From: Venu Busireddy <venu.busireddy@...cle.com>
To: Michael Roth <michael.roth@....com>
Cc: Brijesh Singh <brijesh.singh@....com>, x86@...nel.org,
linux-kernel@...r.kernel.org, kvm@...r.kernel.org,
linux-efi@...r.kernel.org, platform-driver-x86@...r.kernel.org,
linux-coco@...ts.linux.dev, linux-mm@...ck.org,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, Joerg Roedel <jroedel@...e.de>,
Tom Lendacky <thomas.lendacky@....com>,
"H. Peter Anvin" <hpa@...or.com>, Ard Biesheuvel <ardb@...nel.org>,
Paolo Bonzini <pbonzini@...hat.com>,
Sean Christopherson <seanjc@...gle.com>,
Vitaly Kuznetsov <vkuznets@...hat.com>,
Jim Mattson <jmattson@...gle.com>,
Andy Lutomirski <luto@...nel.org>,
Dave Hansen <dave.hansen@...ux.intel.com>,
Sergio Lopez <slp@...hat.com>, Peter Gonda <pgonda@...gle.com>,
Peter Zijlstra <peterz@...radead.org>,
Srinivas Pandruvada <srinivas.pandruvada@...ux.intel.com>,
David Rientjes <rientjes@...gle.com>,
Dov Murik <dovmurik@...ux.ibm.com>,
Tobin Feldman-Fitzthum <tobin@....com>,
Borislav Petkov <bp@...en8.de>,
Vlastimil Babka <vbabka@...e.cz>,
"Kirill A . Shutemov" <kirill@...temov.name>,
Andi Kleen <ak@...ux.intel.com>,
"Dr . David Alan Gilbert" <dgilbert@...hat.com>,
tony.luck@...el.com, marcorr@...gle.com,
sathyanarayanan.kuppuswamy@...ux.intel.com
Subject: Re: [PATCH v8 22/40] x86/sev: move MSR-based VMGEXITs for CPUID to
helper
On 2022-01-06 14:21:35 -0600, Michael Roth wrote:
> On Thu, Jan 06, 2022 at 12:38:37PM -0600, Venu Busireddy wrote:
> > On 2021-12-10 09:43:14 -0600, Brijesh Singh wrote:
> > > From: Michael Roth <michael.roth@....com>
> > >
> > > This code will also be used later for SEV-SNP-validated CPUID code in
> > > some cases, so move it to a common helper.
> > >
> > > Signed-off-by: Michael Roth <michael.roth@....com>
> > > Signed-off-by: Brijesh Singh <brijesh.singh@....com>
Reviewed-by: Venu Busireddy <venu.busireddy@...cle.com>
> > > ---
> > > arch/x86/kernel/sev-shared.c | 84 +++++++++++++++++++++++++-----------
> > > 1 file changed, 58 insertions(+), 26 deletions(-)
> > >
> > > diff --git a/arch/x86/kernel/sev-shared.c b/arch/x86/kernel/sev-shared.c
> > > index 3aaef1a18ffe..d89481b31022 100644
> > > --- a/arch/x86/kernel/sev-shared.c
> > > +++ b/arch/x86/kernel/sev-shared.c
> > > @@ -194,6 +194,58 @@ enum es_result sev_es_ghcb_hv_call(struct ghcb *ghcb, bool set_ghcb_msr,
> > > return verify_exception_info(ghcb, ctxt);
> > > }
> > >
> > > +static int sev_cpuid_hv(u32 func, u32 subfunc, u32 *eax, u32 *ebx,
> > > + u32 *ecx, u32 *edx)
> > > +{
> > > + u64 val;
> > > +
> > > + if (eax) {
> > > + sev_es_wr_ghcb_msr(GHCB_CPUID_REQ(func, GHCB_CPUID_REQ_EAX));
> > > + VMGEXIT();
> > > + val = sev_es_rd_ghcb_msr();
> > > +
> > > + if (GHCB_RESP_CODE(val) != GHCB_MSR_CPUID_RESP)
> > > + return -EIO;
> > > +
> > > + *eax = (val >> 32);
> > > + }
> > > +
> > > + if (ebx) {
> > > + sev_es_wr_ghcb_msr(GHCB_CPUID_REQ(func, GHCB_CPUID_REQ_EBX));
> > > + VMGEXIT();
> > > + val = sev_es_rd_ghcb_msr();
> > > +
> > > + if (GHCB_RESP_CODE(val) != GHCB_MSR_CPUID_RESP)
> > > + return -EIO;
> > > +
> > > + *ebx = (val >> 32);
> > > + }
> > > +
> > > + if (ecx) {
> > > + sev_es_wr_ghcb_msr(GHCB_CPUID_REQ(func, GHCB_CPUID_REQ_ECX));
> > > + VMGEXIT();
> > > + val = sev_es_rd_ghcb_msr();
> > > +
> > > + if (GHCB_RESP_CODE(val) != GHCB_MSR_CPUID_RESP)
> > > + return -EIO;
> > > +
> > > + *ecx = (val >> 32);
> > > + }
> > > +
> > > + if (edx) {
> > > + sev_es_wr_ghcb_msr(GHCB_CPUID_REQ(func, GHCB_CPUID_REQ_EDX));
> > > + VMGEXIT();
> > > + val = sev_es_rd_ghcb_msr();
> > > +
> > > + if (GHCB_RESP_CODE(val) != GHCB_MSR_CPUID_RESP)
> > > + return -EIO;
> > > +
> > > + *edx = (val >> 32);
> > > + }
> > > +
> > > + return 0;
> > > +}
> > > +
> > > /*
> > > * Boot VC Handler - This is the first VC handler during boot, there is no GHCB
> > > * page yet, so it only supports the MSR based communication with the
> > > @@ -202,39 +254,19 @@ enum es_result sev_es_ghcb_hv_call(struct ghcb *ghcb, bool set_ghcb_msr,
> > > void __init do_vc_no_ghcb(struct pt_regs *regs, unsigned long exit_code)
> > > {
> > > unsigned int fn = lower_bits(regs->ax, 32);
> > > - unsigned long val;
> > > + u32 eax, ebx, ecx, edx;
> > >
> > > /* Only CPUID is supported via MSR protocol */
> > > if (exit_code != SVM_EXIT_CPUID)
> > > goto fail;
> > >
> > > - sev_es_wr_ghcb_msr(GHCB_CPUID_REQ(fn, GHCB_CPUID_REQ_EAX));
> > > - VMGEXIT();
> > > - val = sev_es_rd_ghcb_msr();
> > > - if (GHCB_RESP_CODE(val) != GHCB_MSR_CPUID_RESP)
> > > + if (sev_cpuid_hv(fn, 0, &eax, &ebx, &ecx, &edx))
> > > goto fail;
> > > - regs->ax = val >> 32;
> > >
> > > - sev_es_wr_ghcb_msr(GHCB_CPUID_REQ(fn, GHCB_CPUID_REQ_EBX));
> > > - VMGEXIT();
> > > - val = sev_es_rd_ghcb_msr();
> > > - if (GHCB_RESP_CODE(val) != GHCB_MSR_CPUID_RESP)
> > > - goto fail;
> > > - regs->bx = val >> 32;
> > > -
> > > - sev_es_wr_ghcb_msr(GHCB_CPUID_REQ(fn, GHCB_CPUID_REQ_ECX));
> > > - VMGEXIT();
> > > - val = sev_es_rd_ghcb_msr();
> > > - if (GHCB_RESP_CODE(val) != GHCB_MSR_CPUID_RESP)
> > > - goto fail;
> > > - regs->cx = val >> 32;
> > > -
> > > - sev_es_wr_ghcb_msr(GHCB_CPUID_REQ(fn, GHCB_CPUID_REQ_EDX));
> > > - VMGEXIT();
> > > - val = sev_es_rd_ghcb_msr();
> > > - if (GHCB_RESP_CODE(val) != GHCB_MSR_CPUID_RESP)
> > > - goto fail;
> > > - regs->dx = val >> 32;
> > > + regs->ax = eax;
> > > + regs->bx = ebx;
> > > + regs->cx = ecx;
> > > + regs->dx = edx;
> >
> > What is the intent behind declaring e?x as local variables, instead
> > of passing the addresses of regs->?x to sev_cpuid_hv()? Is it to
> > prevent touching any of the regs->?x unless there is no error from
> > sev_cpuid_hv()? If so, wouldn't it be better to hide this logic from
> > the callers by declaring the local variables in sev_cpuid_hv() itself,
> > and moving the four "*e?x = (val >> 32);" statements there to the end
> > of the function (just before last the return)? With that change, the
> > callers can safely pass the addresses of regs->?x to do_vc_no_ghcb(),
> > knowing that the values will only be touched if there is no error?
>
> For me it was more about readability. E?X are well-defined as 32-bit
> values, whereas regs->?x are longs. It seemed more readable to me to
> have sev_cpuid_hv()/snp_cpuid() expect/return the actual native types,
> and leave it up to the caller to cast/shift if necessary.
>
> It also seems more robust for future re-use, since, for instance, if we
> ever introduced another callsite that happened to already use u32 locally,
> it seems like it would be a mess trying to setup up temp long* args or do
> casts to pass them into these functions and then shift/cast them back just
> so we could save a few lines at this particular callsite.
Got it.
Venu
Powered by blists - more mailing lists