[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <cd1ea34d-340c-86c2-16d8-94e689e3edb5@nvidia.com>
Date: Mon, 10 Jan 2022 19:27:47 -0800
From: John Hubbard <jhubbard@...dia.com>
To: "Matthew Wilcox (Oracle)" <willy@...radead.org>, linux-mm@...ck.org
Cc: Christoph Hellwig <hch@...radead.org>,
William Kucharski <william.kucharski@...cle.com>,
linux-kernel@...r.kernel.org, Jason Gunthorpe <jgg@...pe.ca>
Subject: Re: [PATCH v2 07/28] gup: Remove an assumption of a contiguous memmap
On 1/9/22 20:23, Matthew Wilcox (Oracle) wrote:
> This assumption needs the inverse of nth_page(), which I've temporarily
> named page_nth() until someone comes up with a better name.
>
> Signed-off-by: Matthew Wilcox (Oracle) <willy@...radead.org>
> ---
> include/linux/mm.h | 2 ++
> mm/gup.c | 4 ++--
> 2 files changed, 4 insertions(+), 2 deletions(-)
Reviewed-by: John Hubbard <jhubbard@...dia.com>
Maybe a better name for page_nth() will come to mind by the time I
reach the end of this series, we'll see. :)
thanks,
--
John Hubbard
NVIDIA
>
> diff --git a/include/linux/mm.h b/include/linux/mm.h
> index d8b7d7ed14dd..f2f3400665a4 100644
> --- a/include/linux/mm.h
> +++ b/include/linux/mm.h
> @@ -216,8 +216,10 @@ int overcommit_policy_handler(struct ctl_table *, int, void *, size_t *,
>
> #if defined(CONFIG_SPARSEMEM) && !defined(CONFIG_SPARSEMEM_VMEMMAP)
> #define nth_page(page,n) pfn_to_page(page_to_pfn((page)) + (n))
> +#define page_nth(head, tail) (page_to_pfn(tail) - page_to_pfn(head))
> #else
> #define nth_page(page,n) ((page) + (n))
> +#define page_nth(head, tail) ((tail) - (head))
> #endif
>
> /* to align the pointer to the (next) page boundary */
> diff --git a/mm/gup.c b/mm/gup.c
> index 9c0a702a4e03..afb638a30e44 100644
> --- a/mm/gup.c
> +++ b/mm/gup.c
> @@ -238,8 +238,8 @@ static inline struct page *compound_range_next(unsigned long i,
> next = nth_page(start, i);
> page = compound_head(next);
> if (PageHead(page))
> - nr = min_t(unsigned int,
> - page + compound_nr(page) - next, npages - i);
> + nr = min_t(unsigned int, npages - i,
> + compound_nr(page) - page_nth(page, next));
>
> *ntails = nr;
> return page;
Powered by blists - more mailing lists