[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220115183643.6zxalxqxrhkfgdfq@pengutronix.de>
Date: Sat, 15 Jan 2022 19:36:43 +0100
From: Uwe Kleine-König <u.kleine-koenig@...gutronix.de>
To: Sergey Shtylyov <s.shtylyov@....ru>
Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
"Rafael J. Wysocki" <rafael@...nel.org>,
linux-kernel@...r.kernel.org, Andrew Lunn <andrew@...n.ch>,
Ulf Hansson <ulf.hansson@...aro.org>,
Vignesh Raghavendra <vigneshr@...com>,
Jiri Slaby <jirislaby@...nel.org>,
Liam Girdwood <lgirdwood@...il.com>, linux-iio@...r.kernel.org,
Linus Walleij <linus.walleij@...aro.org>,
Amit Kucheria <amitk@...nel.org>, alsa-devel@...a-project.org,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Sebastian Reichel <sre@...nel.org>,
linux-phy@...ts.infradead.org,
Thierry Reding <thierry.reding@...il.com>,
linux-mtd@...ts.infradead.org, linux-i2c@...r.kernel.org,
linux-gpio@...r.kernel.org,
Miquel Raynal <miquel.raynal@...tlin.com>,
Guenter Roeck <groeck@...omium.org>,
Lee Jones <lee.jones@...aro.org>,
openipmi-developer@...ts.sourceforge.net,
Saravanan Sekar <sravanhome@...il.com>,
Khuong Dinh <khuong@...amperecomputing.com>,
Florian Fainelli <f.fainelli@...il.com>,
Matthias Schiffer <matthias.schiffer@...tq-group.com>,
kvm@...r.kernel.org, Kamal Dasu <kdasu.kdev@...il.com>,
Richard Weinberger <richard@....at>,
Bartosz Golaszewski <brgl@...ev.pl>,
Daniel Lezcano <daniel.lezcano@...aro.org>,
Kishon Vijay Abraham I <kishon@...com>,
bcm-kernel-feedback-list@...adcom.com,
linux-serial@...r.kernel.org, Jakub Kicinski <kuba@...nel.org>,
Zhang Rui <rui.zhang@...el.com>,
Jaroslav Kysela <perex@...ex.cz>,
platform-driver-x86@...r.kernel.org, linux-pwm@...r.kernel.org,
John Garry <john.garry@...wei.com>,
Robert Richter <rric@...nel.org>,
Zha Qipeng <qipeng.zha@...el.com>,
Corey Minyard <minyard@....org>, linux-pm@...r.kernel.org,
Peter Korsgaard <peter@...sgaard.com>,
William Breathitt Gray <vilhelm.gray@...il.com>,
Mark Gross <markgross@...nel.org>,
Hans de Goede <hdegoede@...hat.com>,
Alex Williamson <alex.williamson@...hat.com>,
Mark Brown <broonie@...nel.org>,
Borislav Petkov <bp@...en8.de>,
Matthias Brugger <matthias.bgg@...il.com>,
Takashi Iwai <tiwai@...e.com>,
Mauro Carvalho Chehab <mchehab@...nel.org>,
Benson Leung <bleung@...omium.org>,
linux-arm-kernel@...ts.infradead.org, linux-edac@...r.kernel.org,
Tony Luck <tony.luck@...el.com>,
Mun Yew Tham <mun.yew.tham@...el.com>,
Eric Auger <eric.auger@...hat.com>, netdev@...r.kernel.org,
Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>,
Cornelia Huck <cohuck@...hat.com>, linux-mmc@...r.kernel.org,
Joakim Zhang <qiangqing.zhang@....com>,
linux-spi@...r.kernel.org, linux-renesas-soc@...r.kernel.org,
Vinod Koul <vkoul@...nel.org>,
James Morse <james.morse@....com>,
Pengutronix Kernel Team <kernel@...gutronix.de>,
Niklas Söderlund <niklas.soderlund@...natech.se>,
linux-mediatek@...ts.infradead.org,
Brian Norris <computersforpeace@...il.com>,
"David S. Miller" <davem@...emloft.net>
Subject: Re: [PATCH 1/2] platform: make platform_get_irq_optional() optional
(summary)
Hello,
I'm trying to objectively summarize the discussions in this thread in
the hope this helps finding a way that most people can live with.
First a description of the status quo:
There are several function pairs *get() and *get_optional() that however
are different in various aspects. Their relevant properties are listes
in the following table. Ideally each line had only identical entries.
| clk_get | gpiod_get | platform_get_irq | regulator_get |
return value | | | | |
on not-found | ERR_PTR(-ENOENT) | ERR_PTR(-ENOENT) | -ENXIO | dummy[1] |
(plain get) | | | | |
| | | | |
return value | | | | |
on not-found | dummy[1] | dummy[1] | -ENXIO | ERR_PTR(-ENOENT) |
(get_optional) | | | | |
| | | | |
emits an error message | | | | |
on error (including | no | no | yes[2] | no |
not-found) | | | | |
| | | | |
get_optional emits an error | | | | |
message on error (including | no | no | no | no |
not-found) | | | | |
| | | | |
summary: | returning a dummy | returning a dummy | doesn't emit an | returning error code |
*_get_optional() differs from | on not-found | on not-found | error message | on not-found |
*_get by: | | | | |
[1] the dummy value is a valid resource descriptor, the API functions
are a noop for this dummy value. This dummy value is NULL for
all three subsystems.
[2] no error is printed for -EPROBE_DEFER.
The inversion between clk+gpio vs. regulator is unforunate, swaping one
or the other would be good for consistency, but this isn't the topic of
this thread. Only so much: It's not agreed upon which variant is the
better one and the difference is of historical origin.
There are now different suggestions to improve the situation regarding
platform_get_irq() compared to the other functions:
a) by Sergey
platform_get_irq_optional() is changed to return 0 on not-found.
b) by Uwe
rename platform_get_irq_optional() to platform_get_irq_silent()
The argument pro a) is:
platform_get_irq_optional() is aligned to clk_get() and
gpiod_get() by returning 0 on not-found.
The argument contra a)
The return value 0 for platform_get_irq() is only syntactically
nearer to the dummy value of clk_get() and gpiod_get(). A dummy
value isn't available and probably not sensible to introduce for
irq because most drivers have to check for the not-found
situation anyhow to setup polling.
The argument pro b) is:
The relevant difference between platform_get_irq() and its
optional variant is that the latter is silent. This is a
different concept for the meaning of optional compared to the
other *_get_optional().
The argument contra b) is:
The chosen name is bad, because driver authors might wonder what
a silent irq is.
---- end of summary
A possible compromise: We can have both. We rename
platform_get_irq_optional() to platform_get_irq_silent() (or
platform_get_irq_silently() if this is preferred) and once all users are
are changed (which can be done mechanically), we reintroduce a
platform_get_irq_optional() with Sergey's suggested semantic (i.e.
return 0 on not-found, no error message printking).
Best regards
Uwe
--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | https://www.pengutronix.de/ |
Download attachment "signature.asc" of type "application/pgp-signature" (489 bytes)
Powered by blists - more mailing lists