lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Mon, 17 Jan 2022 15:14:52 +0000
From:   Yazen Ghannam <yazen.ghannam@....com>
To:     Borislav Petkov <bp@...en8.de>
Cc:     linux-edac@...r.kernel.org, linux-kernel@...r.kernel.org,
        tony.luck@...el.com, x86@...nel.org,
        Smita.KoralahalliChannabasappa@....com
Subject: Re: [PATCH] x86/MCE/AMD: Allow thresholding interface updates after
 init

On Wed, Dec 29, 2021 at 06:42:18PM +0100, Borislav Petkov wrote:
> On Tue, Dec 07, 2021 at 07:30:28PM +0000, Yazen Ghannam wrote:
> > Changes to the AMD Thresholding sysfs code prevents sysfs writes from
> > updating the underlying registers once CPU init is completed, i.e.
> > "threshold_banks" is set.
> > 
> > Allow the registers to be updated if the thresholding interface is
> > already initialized or if in the init path. Use the "set_lvt_off" value
> > to indicate if running in the init path, since this value is only set
> > during init.
> > 
> > Fixes: a037f3ca0ea0 ("x86/mce/amd: Make threshold bank setting hotplug robust")
> > Signed-off-by: Yazen Ghannam <yazen.ghannam@....com>
> 
> We want that in stable, right?
>

Yes, thanks for catching that.
 
> > ---
> >  arch/x86/kernel/cpu/mce/amd.c | 8 ++++++--
> >  1 file changed, 6 insertions(+), 2 deletions(-)
> > 
> > diff --git a/arch/x86/kernel/cpu/mce/amd.c b/arch/x86/kernel/cpu/mce/amd.c
> > index 2eadc7c4c902..408c9546ea0b 100644
> > --- a/arch/x86/kernel/cpu/mce/amd.c
> > +++ b/arch/x86/kernel/cpu/mce/amd.c
> > @@ -400,8 +400,12 @@ static void threshold_restart_bank(void *_tr)
> >  	struct thresh_restart *tr = _tr;
> >  	u32 hi, lo;
> >  
> > -	/* sysfs write might race against an offline operation */
> > -	if (this_cpu_read(threshold_banks))
> > +	/*
> > +	 * sysfs write might race against an offline operation.
> > +	 * Prevent register writes if threshold_banks are not set and this is
> > +	 * not called from the init path as indicated by "set_lvt_off".
> > +	 */
> 
> So if you convert this text into code, it would read like:
> 
> 	if (!this_cpu_read(threshold_banks) && !tr->set_lvt_off)
> 
> which is equivalent to:
> 
> > +	if (!(this_cpu_read(threshold_banks) || tr->set_lvt_off))
> 
> but easier to follow, methinks.
>

Sure, I'll make the change and send another version.

Thanks,
Yazen 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ