[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YeaBCYiTM/mxtBDU@hirez.programming.kicks-ass.net>
Date: Tue, 18 Jan 2022 09:57:45 +0100
From: Peter Zijlstra <peterz@...radead.org>
To: Kees Cook <keescook@...omium.org>
Cc: Steven Rostedt <rostedt@...dmis.org>,
Xiu Jianfeng <xiujianfeng@...wei.com>, mingo@...hat.com,
juri.lelli@...hat.com, vincent.guittot@...aro.org,
dietmar.eggemann@....com, bsegall@...gle.com, mgorman@...e.de,
bristot@...hat.com, gustavoars@...nel.org,
linux-kernel@...r.kernel.org, linux-hardening@...r.kernel.org,
Linus Torvalds <torvalds@...ux-foundation.org>
Subject: Re: [PATCH -next, v2] sched: Use struct_size() helper in
task_numa_group()
On Fri, Jan 14, 2022 at 07:50:47PM -0800, Kees Cook wrote:
> On Thu, Jan 13, 2022 at 10:18:57AM +0100, Peter Zijlstra wrote:
> > Then I would still much prefer something like:
> >
> > unsigned int size = sizeof(*grp) +
> > NR_NUMA_HINT_FAULT_STATS * numa_node_ids * sizeof(gfp->faults);
> >
> > Which is still far more readable than some obscure macro. But again, the
>
> I'm not sure it's _obscure_, but it is relatively new. It's even
> documented. ;)
> https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
I'm one of those people who doesn't read documentation, I read code.
I also flat out refuse to read any documentation that isn't plain text.
> > I can't, nor do I want to, remember all these stupid little macros. Esp.
> > not for trivial things like this.
>
> Well, the good news is that other folks will (and are) fixing them for
> you. :) Even if you never make mistakes with flexible arrays, other
> people do, and so we need to take on some improvements to the robustness
> of the kernel source tree-wide.
But nobody helps me read the code when I trip over crap like this :/ Why
do we have to have endless silly helpers for things that can be
trivially expressed in regular C? I appreciate things like
container_of() because if you write that out it's a mess, but this, very
much not so.
struct_size(grp, faults, NR_NUMA_HINT_FAULTS_STATS * numa_node_ids);
vs
sizeof(*gfp) + sizeof(grp->faults) * NR_NUMA_HINT_FAULT_STATS * nr_node_ids;
The latter wins hands down, instantly obvious what it does while with
the former I'd have to look up the macro.
Powered by blists - more mailing lists