lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 19 Jan 2022 11:16:50 +0200
From:   Sakari Ailus <sakari.ailus@...ux.intel.com>
To:     "Tu, ShawnX" <shawnx.tu@...el.com>
Cc:     lkp <lkp@...el.com>, "llvm@...ts.linux.dev" <llvm@...ts.linux.dev>,
        "kbuild-all@...ts.01.org" <kbuild-all@...ts.01.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [sailus-media-tree:master 15/16]
 drivers/media/i2c/hi847.c:2700:35: error: incompatible pointer types passing
 'struct v4l2_subdev_pad_config *' to parameter of type 'struct
 v4l2_subdev_state *'

Hi Shawn,

On Wed, Jan 19, 2022 at 03:06:09AM +0000, Tu, ShawnX wrote:
> Hi Sakari,
> 
> It has uploaded fixed V2 patch to the server.
> * [PATCH v2] media: hi847: Add support for Hi-847 sensor
> https://github.com/0day-ci/linux/commits/Shawnx-Tu/media-hi847-Add-support-for-Hi-847-sensor/20220113-120102
> 
> But I still see the lkp build error message and use previous V1 patch to build.
> Could you help to check? If needs to fix the driver, I'll upload new one.

I've replaced the earlier one by v2 in my tree.

-- 
Sakari Ailus

Powered by blists - more mailing lists