[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <b7d0e7572ce7f7958f579ac564d25cbfee497cdc.camel@mediatek.com>
Date: Thu, 20 Jan 2022 14:31:55 +0800
From: Chunfeng Yun <chunfeng.yun@...iatek.com>
To: "Gustavo A. R. Silva" <gustavoars@...nel.org>,
Mathias Nyman <mathias.nyman@...el.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Matthias Brugger <matthias.bgg@...il.com>
CC: <linux-usb@...r.kernel.org>,
<linux-arm-kernel@...ts.infradead.org>,
<linux-mediatek@...ts.infradead.org>,
<linux-kernel@...r.kernel.org>, <linux-hardening@...r.kernel.org>
Subject: Re: [PATCH][next] usb: xhci-mtk: Use struct_size() helper in
create_sch_ep()
On Wed, 2022-01-19 at 19:55 -0600, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded
> version,
> in order to avoid any potential type mistakes or integer overflows
> that,
> in the worst scenario, could lead to heap overflows.
>
> Also, address the following sparse warnings:
> drivers/usb/host/xhci-mtk-sch.c:265:20: warning: using sizeof on a
> flexible structure
>
> Link: https://github.com/KSPP/linux/issues/160
> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org>
> ---
> drivers/usb/host/xhci-mtk-sch.c | 7 +++----
> 1 file changed, 3 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/usb/host/xhci-mtk-sch.c b/drivers/usb/host/xhci-
> mtk-sch.c
> index edbfa82c6565..f3139ce7b0a9 100644
> --- a/drivers/usb/host/xhci-mtk-sch.c
> +++ b/drivers/usb/host/xhci-mtk-sch.c
> @@ -248,7 +248,6 @@ create_sch_ep(struct xhci_hcd_mtk *mtk, struct
> usb_device *udev,
> struct mu3h_sch_bw_info *bw_info;
> struct mu3h_sch_tt *tt = NULL;
> u32 len_bw_budget_table;
> - size_t mem_size;
>
> bw_info = get_bw_info(mtk, udev, ep);
> if (!bw_info)
> @@ -262,9 +261,9 @@ create_sch_ep(struct xhci_hcd_mtk *mtk, struct
> usb_device *udev,
> else
> len_bw_budget_table = 1;
>
> - mem_size = sizeof(struct mu3h_sch_ep_info) +
> - len_bw_budget_table * sizeof(u32);
> - sch_ep = kzalloc(mem_size, GFP_KERNEL);
> + sch_ep = kzalloc(struct_size(sch_ep, bw_budget_table,
> + len_bw_budget_table),
> + GFP_KERNEL);
> if (!sch_ep)
> return ERR_PTR(-ENOMEM);
Acked-by: Chunfeng Yun <chunfeng.yun@...iatek.com>
Thanks a lot
>
Powered by blists - more mailing lists