[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <0d9a0ce5-ab34-cf05-158e-e25fc5595b4d@gmail.com>
Date: Tue, 25 Jan 2022 11:24:52 +0100
From: Rafał Miłecki <zajec5@...il.com>
To: Michael Walle <michael@...le.cc>, linux-mtd@...ts.infradead.org,
devicetree@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, netdev@...r.kernel.org
Cc: Miquel Raynal <miquel.raynal@...tlin.com>,
Richard Weinberger <richard@....at>,
Vignesh Raghavendra <vigneshr@...com>,
Rob Herring <robh+dt@...nel.org>,
Srinivas Kandagatla <srinivas.kandagatla@...aro.org>,
Shawn Guo <shawnguo@...nel.org>, Li Yang <leoyang.li@....com>,
Frank Rowand <frowand.list@...il.com>,
"David S . Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>,
Ansuel Smith <ansuelsmth@...il.com>,
Andrew Lunn <andrew@...n.ch>
Subject: Re: [PATCH 5/8] net: add helper eth_addr_add()
On 28.12.2021 15:25, Michael Walle wrote:
> Add a helper to add an offset to a ethernet address. This comes in handy
> if you have a base ethernet address for multiple interfaces.
>
> Signed-off-by: Michael Walle <michael@...le.cc>
> ---
> include/linux/etherdevice.h | 14 ++++++++++++++
> 1 file changed, 14 insertions(+)
>
> diff --git a/include/linux/etherdevice.h b/include/linux/etherdevice.h
> index 2ad71cc90b37..9d621dc85290 100644
> --- a/include/linux/etherdevice.h
> +++ b/include/linux/etherdevice.h
> @@ -486,6 +486,20 @@ static inline void eth_addr_inc(u8 *addr)
> u64_to_ether_addr(u, addr);
> }
>
> +/**
> + * eth_addr_add() - Add (or subtract) and offset to/from the given MAC address.
> + *
> + * @offset: Offset to add.
> + * @addr: Pointer to a six-byte array containing Ethernet address to increment.
> + */
> +static inline void eth_addr_add(u8 *addr, long offset)
> +{
> + u64 u = ether_addr_to_u64(addr);
> +
> + u += offset;
> + u64_to_ether_addr(u, addr);
> +}
Please check eth_hw_addr_gen() which contains identical code +
eth_hw_addr_set().
You should probably make eth_hw_addr_gen() use your new function as a
helper.
Powered by blists - more mailing lists