[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <87pmoen4ro.fsf@nvidia.com>
Date: Wed, 26 Jan 2022 11:55:04 +0100
From: Petr Machata <petrm@...dia.com>
To: "Gustavo A. R. Silva" <gustavoars@...nel.org>
CC: Ido Schimmel <idosch@...dia.com>, Petr Machata <petrm@...dia.com>,
"David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>, <netdev@...r.kernel.org>,
<linux-kernel@...r.kernel.org>, <linux-hardening@...r.kernel.org>
Subject: Re: [PATCH][next] mlxsw: spectrum_kvdl: Use struct_size() helper in
kzalloc()
"Gustavo A. R. Silva" <gustavoars@...nel.org> writes:
> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
>
> Also, address the following sparse warnings:
> drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c:229:24: warning: using sizeof on a flexible structure
>
> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@...nel.org>
> ---
> drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c b/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
> index a9fff8adc75e..d20e794e01ca 100644
> --- a/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
> +++ b/drivers/net/ethernet/mellanox/mlxsw/spectrum1_kvdl.c
> @@ -213,7 +213,6 @@ mlxsw_sp1_kvdl_part_init(struct mlxsw_sp *mlxsw_sp,
> struct mlxsw_sp1_kvdl_part *part;
> bool need_update = true;
> unsigned int nr_entries;
> - size_t usage_size;
> u64 resource_size;
> int err;
>
> @@ -225,8 +224,8 @@ mlxsw_sp1_kvdl_part_init(struct mlxsw_sp *mlxsw_sp,
> }
>
> nr_entries = div_u64(resource_size, info->alloc_size);
> - usage_size = BITS_TO_LONGS(nr_entries) * sizeof(unsigned long);
> - part = kzalloc(sizeof(*part) + usage_size, GFP_KERNEL);
> + part = kzalloc(struct_size(part, usage, BITS_TO_LONGS(nr_entries)),
> + GFP_KERNEL);
> if (!part)
> return ERR_PTR(-ENOMEM);
Reviewed-by: Petr Machata <petrm@...dia.com>
Powered by blists - more mailing lists