[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <62d2a231-3d05-5008-fae2-335c4ad853bd@collabora.com>
Date: Thu, 27 Jan 2022 12:02:08 +0100
From: AngeloGioacchino Del Regno
<angelogioacchino.delregno@...labora.com>
To: Yong Wu <yong.wu@...iatek.com>, Joerg Roedel <joro@...tes.org>,
Rob Herring <robh+dt@...nel.org>,
Matthias Brugger <matthias.bgg@...il.com>,
Will Deacon <will@...nel.org>
Cc: Robin Murphy <robin.murphy@....com>,
Krzysztof Kozlowski <krzysztof.kozlowski@...onical.com>,
Tomasz Figa <tfiga@...omium.org>,
linux-mediatek@...ts.infradead.org, srv_heupstream@...iatek.com,
devicetree@...r.kernel.org, linux-kernel@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org,
iommu@...ts.linux-foundation.org,
Hsin-Yi Wang <hsinyi@...omium.org>, youlin.pei@...iatek.com,
anan.sun@...iatek.com, xueqi.zhang@...iatek.com,
yen-chang.chen@...iatek.com, mingyuan.ma@...iatek.com,
yf.wang@...iatek.com, libo.kang@...iatek.com,
chengci.xu@...iatek.com
Subject: Re: [PATCH v4 06/35] iommu/mediatek: Add mutex for m4u_group and
m4u_dom in data
Il 25/01/22 09:56, Yong Wu ha scritto:
> Add a mutex to protect the data in the structure mtk_iommu_data,
> like ->"m4u_group" ->"m4u_dom". For the internal data, we should
> protect it in ourselves driver. Add a mutex for this.
> This could be a fix for the multi-groups support.
>
> Fixes: c3045f39244e ("iommu/mediatek: Support for multi domains")
> Signed-off-by: Yunfei Wang <yf.wang@...iatek.com>
> Signed-off-by: Yong Wu <yong.wu@...iatek.com>
> ---
> drivers/iommu/mtk_iommu.c | 13 +++++++++++--
> drivers/iommu/mtk_iommu.h | 2 ++
> 2 files changed, 13 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/iommu/mtk_iommu.c b/drivers/iommu/mtk_iommu.c
> index ec2c387abf60..095736bfb7b4 100644
> --- a/drivers/iommu/mtk_iommu.c
> +++ b/drivers/iommu/mtk_iommu.c
> @@ -464,15 +464,16 @@ static int mtk_iommu_attach_device(struct iommu_domain *domain,
> dom->data = data;
> }
>
> + mutex_lock(&data->mutex);
> if (!data->m4u_dom) { /* Initialize the M4U HW */
> ret = pm_runtime_resume_and_get(m4udev);
> if (ret < 0)
> - return ret;
> + goto data_unlock;
In order to enhance human readability, I would rather propose:
goto err_unlock;
Apart from this,
Reviewed-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@...labora.com>
>
> ret = mtk_iommu_hw_init(data);
> if (ret) {
> pm_runtime_put(m4udev);
> - return ret;
> + goto data_unlock;
> }
> data->m4u_dom = dom;
> writel(dom->cfg.arm_v7s_cfg.ttbr & MMU_PT_ADDR_MASK,
> @@ -480,9 +481,14 @@ static int mtk_iommu_attach_device(struct iommu_domain *domain,
>
> pm_runtime_put(m4udev);
> }
> + mutex_unlock(&data->mutex);
>
> mtk_iommu_config(data, dev, true, domid);
> return 0;
> +
> +data_unlock:
> + mutex_unlock(&data->mutex);
> + return ret;
> }
>
> static void mtk_iommu_detach_device(struct iommu_domain *domain,
> @@ -592,6 +598,7 @@ static struct iommu_group *mtk_iommu_device_group(struct device *dev)
> if (domid < 0)
> return ERR_PTR(domid);
>
> + mutex_lock(&data->mutex);
> group = data->m4u_group[domid];
> if (!group) {
> group = iommu_group_alloc();
> @@ -600,6 +607,7 @@ static struct iommu_group *mtk_iommu_device_group(struct device *dev)
> } else {
> iommu_group_ref_get(group);
> }
> + mutex_unlock(&data->mutex);
> return group;
> }
>
> @@ -874,6 +882,7 @@ static int mtk_iommu_probe(struct platform_device *pdev)
> }
>
> platform_set_drvdata(pdev, data);
> + mutex_init(&data->mutex);
>
> ret = iommu_device_sysfs_add(&data->iommu, dev, NULL,
> "mtk-iommu.%pa", &ioaddr);
> diff --git a/drivers/iommu/mtk_iommu.h b/drivers/iommu/mtk_iommu.h
> index f81fa8862ed0..f413546ac6e5 100644
> --- a/drivers/iommu/mtk_iommu.h
> +++ b/drivers/iommu/mtk_iommu.h
> @@ -80,6 +80,8 @@ struct mtk_iommu_data {
>
> struct dma_iommu_mapping *mapping; /* For mtk_iommu_v1.c */
>
> + struct mutex mutex; /* Protect m4u_group/m4u_dom above */
> +
> struct list_head list;
> struct mtk_smi_larb_iommu larb_imu[MTK_LARB_NR_MAX];
> };
>
Powered by blists - more mailing lists