[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87f171f1-c44b-5103-f9e5-20a6b5c257dd@intel.com>
Date: Tue, 1 Feb 2022 09:40:06 -0800
From: Dave Hansen <dave.hansen@...el.com>
To: ira.weiny@...el.com, Dave Hansen <dave.hansen@...ux.intel.com>,
"H. Peter Anvin" <hpa@...or.com>,
Dan Williams <dan.j.williams@...el.com>
Cc: Fenghua Yu <fenghua.yu@...el.com>,
Rick Edgecombe <rick.p.edgecombe@...el.com>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH V8 16/44] mm/pkeys: Introduce pks_mk_readwrite()
On 1/27/22 09:54, ira.weiny@...el.com wrote:
> +static inline void pks_mk_readwrite(int pkey)
> +{
> + pks_update_protection(pkey, PKEY_READ_WRITE);
> +}
I don't really like the "mk" terminology in here. Maybe it's from
dealing with the PTE helpers, but "mk" to me means that it won't do
anything observable by itself. We're also not starved for space here,
and it's really odd to abbreviate "make->mk" but not do "readwrite->rw".
This really is going off and changing a register value. I think:
pks_set_readwrite()
would be fine. This starts to get a bit redundant, but looks fine too:
pks_set_key_readwrite()
Powered by blists - more mailing lists