[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <281475cc-a159-8e25-f5e7-cde343bc50c4@opensource.wdc.com>
Date: Mon, 7 Feb 2022 12:25:04 +0900
From: Damien Le Moal <damien.lemoal@...nsource.wdc.com>
To: Yang Li <yang.lee@...ux.alibaba.com>, jejb@...ux.ibm.com
Cc: martin.petersen@...cle.com, jinpu.wang@...ud.ionos.com,
linux-scsi@...r.kernel.org, linux-kernel@...r.kernel.org,
Abaci Robot <abaci@...ux.alibaba.com>
Subject: Re: [PATCH -next] scsi: pm8001: clean up some inconsistent indenting
On 2/6/22 21:55, Yang Li wrote:
> Eliminate the follow smatch warning:
> drivers/scsi/pm8001/pm8001_ctl.c:760 pm8001_update_flash() warn:
> inconsistent indenting
>
> Reported-by: Abaci Robot <abaci@...ux.alibaba.com>
> Signed-off-by: Yang Li <yang.lee@...ux.alibaba.com>
> ---
> drivers/scsi/pm8001/pm8001_ctl.c | 65 +++++++++++++++++---------------
> 1 file changed, 35 insertions(+), 30 deletions(-)
>
> diff --git a/drivers/scsi/pm8001/pm8001_ctl.c b/drivers/scsi/pm8001/pm8001_ctl.c
> index 41a63c9b719b..213ebf39261f 100644
> --- a/drivers/scsi/pm8001/pm8001_ctl.c
> +++ b/drivers/scsi/pm8001/pm8001_ctl.c
> @@ -755,36 +755,41 @@ static int pm8001_update_flash(struct pm8001_hba_info *pm8001_ha)
> fwControl->retcode = 0;/* OUT */
> fwControl->offset = loopNumber * IOCTL_BUF_SIZE;/*OUT */
>
> - /* for the last chunk of data in case file size is not even with
> - 4k, load only the rest*/
> - if (((loopcount-loopNumber) == 1) &&
> - ((partitionSize + HEADER_LEN) % IOCTL_BUF_SIZE)) {
> - fwControl->len =
> - (partitionSize + HEADER_LEN) % IOCTL_BUF_SIZE;
> - memcpy((u8 *)fwControl->buffer,
> - (u8 *)pm8001_ha->fw_image->data + sizeRead,
> - (partitionSize + HEADER_LEN) % IOCTL_BUF_SIZE);
> - sizeRead +=
> - (partitionSize + HEADER_LEN) % IOCTL_BUF_SIZE;
> - } else {
> - memcpy((u8 *)fwControl->buffer,
> - (u8 *)pm8001_ha->fw_image->data + sizeRead,
> - IOCTL_BUF_SIZE);
> - sizeRead += IOCTL_BUF_SIZE;
> - }
> -
> - pm8001_ha->nvmd_completion = &completion;
> - ret = PM8001_CHIP_DISP->fw_flash_update_req(pm8001_ha, payload);
> - if (ret) {
> - pm8001_ha->fw_status = FAIL_OUT_MEMORY;
> - goto out;
> - }
> - wait_for_completion(&completion);
> - if (fwControl->retcode > FLASH_UPDATE_IN_PROGRESS) {
> - pm8001_ha->fw_status = fwControl->retcode;
> - ret = -EFAULT;
> - goto out;
> - }
> + /* for the last chunk of data in case file
> + * size is not even with 4k, load only the rest
> + */
Please start multi-line comments with a line that has only "/*". It
would be good to add a blnak line before that too, for readability.
> + if (((loopcount-loopNumber) == 1) &&
> + ((partitionSize + HEADER_LEN) % IOCTL_BUF_SIZE)) {
While at it, align the conditions together to make this code more
readable. As is, it is really unpleasant to read :)
Also, "(partitionSize + HEADER_LEN) % IOCTL_BUF_SIZE" is calculated way
too many times. Using a local variable for the value would be nice.
> + fwControl->len =
> + (partitionSize + HEADER_LEN) %
> + IOCTL_BUF_SIZE;
> + memcpy((u8 *)fwControl->buffer,
> + (u8 *)pm8001_ha->fw_image->data + sizeRead,
> + (partitionSize + HEADER_LEN) %
> + IOCTL_BUF_SIZE);
> + sizeRead +=
> + (partitionSize + HEADER_LEN) %
> + IOCTL_BUF_SIZE;
> + } else {
> + memcpy((u8 *)fwControl->buffer,
> + (u8 *)pm8001_ha->fw_image->data + sizeRead,
> + IOCTL_BUF_SIZE);
> + sizeRead += IOCTL_BUF_SIZE;
> + }
> +
> + pm8001_ha->nvmd_completion = &completion;
> + ret = PM8001_CHIP_DISP->fw_flash_update_req(pm8001_ha,
> + payload);
> + if (ret) {
> + pm8001_ha->fw_status = FAIL_OUT_MEMORY;
> + goto out;
> + }
> + wait_for_completion(&completion);
> + if (fwControl->retcode > FLASH_UPDATE_IN_PROGRESS) {
> + pm8001_ha->fw_status = fwControl->retcode;
> + ret = -EFAULT;
> + goto out;
> + }
> }
> }
> out:
--
Damien Le Moal
Western Digital Research
Powered by blists - more mailing lists