[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8f307e8a-5f97-cf5d-0a77-1c79b05abd60@suse.cz>
Date: Thu, 17 Feb 2022 10:23:11 +0100
From: Vlastimil Babka <vbabka@...e.cz>
To: Miaohe Lin <linmiaohe@...wei.com>, akpm@...ux-foundation.org,
cl@...ux.com, penberg@...nel.org, rientjes@...gle.com,
iamjoonsoo.kim@....com
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mm/slab_common: use helper function is_power_of_2()
On 2/17/22 10:16, Miaohe Lin wrote:
> Use helper function is_power_of_2() to check if KMALLOC_MIN_SIZE is power
> of two. Minor readability improvement.
>
> Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
We can try, but in case some compiler will no longer able to perform the
check at build-time (although is_power_of_2() looks sufficiently trivial
too), we'll have to revert it.
> ---
> mm/slab_common.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/mm/slab_common.c b/mm/slab_common.c
> index 23f2ab0713b7..6ee64d6208b3 100644
> --- a/mm/slab_common.c
> +++ b/mm/slab_common.c
> @@ -807,7 +807,7 @@ void __init setup_kmalloc_cache_index_table(void)
> unsigned int i;
>
> BUILD_BUG_ON(KMALLOC_MIN_SIZE > 256 ||
> - (KMALLOC_MIN_SIZE & (KMALLOC_MIN_SIZE - 1)));
> + !is_power_of_2(KMALLOC_MIN_SIZE));
>
> for (i = 8; i < KMALLOC_MIN_SIZE; i += 8) {
> unsigned int elem = size_index_elem(i);
Powered by blists - more mailing lists