[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220222111222.56877-1-linmiaohe@huawei.com>
Date: Tue, 22 Feb 2022 19:12:22 +0800
From: Miaohe Lin <linmiaohe@...wei.com>
To: <boris.ostrovsky@...cle.com>, <jgross@...e.com>
CC: <sstabellini@...nel.org>, <xen-devel@...ts.xenproject.org>,
<linux-kernel@...r.kernel.org>, <linmiaohe@...wei.com>
Subject: [PATCH] xen: use helper macro __ATTR_RW
Use helper macro __ATTR_RW to define hyp_sysfs_attr to make code more
clear. Minor readability improvement.
Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
---
drivers/xen/sys-hypervisor.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/xen/sys-hypervisor.c b/drivers/xen/sys-hypervisor.c
index feb1d16252e7..5e842c88a13e 100644
--- a/drivers/xen/sys-hypervisor.c
+++ b/drivers/xen/sys-hypervisor.c
@@ -25,8 +25,7 @@
static struct hyp_sysfs_attr _name##_attr = __ATTR_RO(_name)
#define HYPERVISOR_ATTR_RW(_name) \
-static struct hyp_sysfs_attr _name##_attr = \
- __ATTR(_name, 0644, _name##_show, _name##_store)
+static struct hyp_sysfs_attr _name##_attr = __ATTR_RW(_name)
struct hyp_sysfs_attr {
struct attribute attr;
--
2.23.0
Powered by blists - more mailing lists