[<prev] [next>] [day] [month] [year] [list]
Message-ID: <20220222112034.48298-1-linmiaohe@huawei.com>
Date: Tue, 22 Feb 2022 19:20:34 +0800
From: Miaohe Lin <linmiaohe@...wei.com>
To: <akpm@...ux-foundation.org>
CC: <linux-kernel@...r.kernel.org>, <linmiaohe@...wei.com>
Subject: [PATCH] kernel/ksysfs.c: use helper macro __ATTR_RW
Use helper macro __ATTR_RW to define kobj_attribute to make code more
clear. Minor readability improvement.
Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
---
kernel/ksysfs.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/kernel/ksysfs.c b/kernel/ksysfs.c
index 35859da8bd4f..b1292a57c2a5 100644
--- a/kernel/ksysfs.c
+++ b/kernel/ksysfs.c
@@ -24,8 +24,7 @@
static struct kobj_attribute _name##_attr = __ATTR_RO(_name)
#define KERNEL_ATTR_RW(_name) \
-static struct kobj_attribute _name##_attr = \
- __ATTR(_name, 0644, _name##_show, _name##_store)
+static struct kobj_attribute _name##_attr = __ATTR_RW(_name)
/* current uevent sequence number */
static ssize_t uevent_seqnum_show(struct kobject *kobj,
--
2.23.0
Powered by blists - more mailing lists