[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <6383a6b9-5e03-25e3-922e-97240d7b59ca@oracle.com>
Date: Tue, 22 Feb 2022 16:27:12 -0800
From: Mike Kravetz <mike.kravetz@...cle.com>
To: Miaohe Lin <linmiaohe@...wei.com>, akpm@...ux-foundation.org
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mm/hugetlb: use helper macro __ATTR_RW
On 2/22/22 03:27, Miaohe Lin wrote:
> Use helper macro __ATTR_RW to define HSTATE_ATTR to make code more
> clear. Minor readability improvement.
>
> Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
> ---
> mm/hugetlb.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
Thanks!
I should have noticed and changed that when adding HSTATE_ATTR_WO.
Reviewed-by: Mike Kravetz <mike.kravetz@...cle.com>
--
Mike Kravetz
>
> diff --git a/mm/hugetlb.c b/mm/hugetlb.c
> index 1f0cca036f7f..c0405f3c8413 100644
> --- a/mm/hugetlb.c
> +++ b/mm/hugetlb.c
> @@ -3498,8 +3498,7 @@ static int demote_pool_huge_page(struct hstate *h, nodemask_t *nodes_allowed)
> static struct kobj_attribute _name##_attr = __ATTR_WO(_name)
>
> #define HSTATE_ATTR(_name) \
> - static struct kobj_attribute _name##_attr = \
> - __ATTR(_name, 0644, _name##_show, _name##_store)
> + static struct kobj_attribute _name##_attr = __ATTR_RW(_name)
>
> static struct kobject *hugepages_kobj;
> static struct kobject *hstate_kobjs[HUGE_MAX_HSTATE];
Powered by blists - more mailing lists