[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220224235206.GA302751@bhelgaas>
Date: Thu, 24 Feb 2022 17:52:06 -0600
From: Bjorn Helgaas <helgaas@...nel.org>
To: Krzysztof Kozlowski <krzysztof.kozlowski@...onical.com>
Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
"Rafael J. Wysocki" <rafael@...nel.org>,
Stuart Yoder <stuyoder@...il.com>,
Laurentiu Tudor <laurentiu.tudor@....com>,
Abel Vesa <abel.vesa@....com>, Shawn Guo <shawnguo@...nel.org>,
Sascha Hauer <s.hauer@...gutronix.de>,
Fabio Estevam <festevam@...il.com>,
"K. Y. Srinivasan" <kys@...rosoft.com>,
Haiyang Zhang <haiyangz@...rosoft.com>,
Stephen Hemminger <sthemmin@...rosoft.com>,
Wei Liu <wei.liu@...nel.org>, Dexuan Cui <decui@...rosoft.com>,
Bjorn Helgaas <bhelgaas@...gle.com>,
Bjorn Andersson <bjorn.andersson@...aro.org>,
Mathieu Poirier <mathieu.poirier@...aro.org>,
Vineeth Vijayan <vneethv@...ux.ibm.com>,
Peter Oberparleiter <oberpar@...ux.ibm.com>,
Heiko Carstens <hca@...ux.ibm.com>,
Vasily Gorbik <gor@...ux.ibm.com>,
Alexander Gordeev <agordeev@...ux.ibm.com>,
Christian Borntraeger <borntraeger@...ux.ibm.com>,
Sven Schnelle <svens@...ux.ibm.com>,
Andy Gross <agross@...nel.org>,
Srinivas Kandagatla <srinivas.kandagatla@...aro.org>,
Mark Brown <broonie@...nel.org>,
"Michael S. Tsirkin" <mst@...hat.com>,
Jason Wang <jasowang@...hat.com>, linux-kernel@...r.kernel.org,
linux-clk@...r.kernel.org, NXP Linux Team <linux-imx@....com>,
linux-arm-kernel@...ts.infradead.org, linux-hyperv@...r.kernel.org,
linux-pci@...r.kernel.org, linux-remoteproc@...r.kernel.org,
linux-s390@...r.kernel.org, linux-arm-msm@...r.kernel.org,
alsa-devel@...a-project.org, linux-spi@...r.kernel.org,
virtualization@...ts.linux-foundation.org,
Linus Torvalds <torvalds@...ux-foundation.org>,
Rasmus Villemoes <linux@...musvillemoes.dk>
Subject: Re: [PATCH v2 05/11] pci: use helper for safer setting of
driver_override
On Thu, Feb 24, 2022 at 08:49:15AM +0100, Krzysztof Kozlowski wrote:
> On 23/02/2022 22:51, Bjorn Helgaas wrote:
> > In subject, to match drivers/pci/ convention, do something like:
> >
> > PCI: Use driver_set_override() instead of open-coding
> >
> > On Wed, Feb 23, 2022 at 08:13:04PM +0100, Krzysztof Kozlowski wrote:
> >> Use a helper for seting driver_override to reduce amount of duplicated
> >> code.
> >> @@ -567,31 +567,15 @@ static ssize_t driver_override_store(struct device *dev,
> >> const char *buf, size_t count)
> >> {
> >> struct pci_dev *pdev = to_pci_dev(dev);
> >> - char *driver_override, *old, *cp;
> >> + int ret;
> >>
> >> /* We need to keep extra room for a newline */
> >> if (count >= (PAGE_SIZE - 1))
> >> return -EINVAL;
> >
> > This check makes no sense in the new function. Michael alluded to
> > this as well.
>
> I am not sure if I got your comment properly. You mean here:
> 1. Move this check to driver_set_override()?
> 2. Remove the check entirely?
I was mistaken about the purpose of the comment and the check. I
thought it had to do with *this* function, and this function doesn't
add a newline, and there's no obvious connection with PAGE_SIZE.
But looking closer, I think the "extra room for a newline" is really
to make sure that *driver_override_show()* can add a newline and have
it still fit within the PAGE_SIZE sysfs limit.
Most driver_override_*() functions have the same comment, so maybe
this was obvious to everybody except me :) I do see that spi.c adds
"when displaying value" at the end, which helps a lot.
Sorry for the wild goose chase.
> >> - driver_override = kstrndup(buf, count, GFP_KERNEL);
> >> - if (!driver_override)
> >> - return -ENOMEM;
> >> -
> >> - cp = strchr(driver_override, '\n');
> >> - if (cp)
> >> - *cp = '\0';
> >> -
> >> - device_lock(dev);
> >> - old = pdev->driver_override;
> >> - if (strlen(driver_override)) {
> >> - pdev->driver_override = driver_override;
> >> - } else {
> >> - kfree(driver_override);
> >> - pdev->driver_override = NULL;
> >> - }
> >> - device_unlock(dev);
> >> -
> >> - kfree(old);
> >> + ret = driver_set_override(dev, &pdev->driver_override, buf);
> >> + if (ret)
> >> + return ret;
> >>
> >> return count;
> >> }
> >> --
> >> 2.32.0
> >>
> >>
> >> _______________________________________________
> >> linux-arm-kernel mailing list
> >> linux-arm-kernel@...ts.infradead.org
> >> http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
>
>
> Best regards,
> Krzysztof
>
> _______________________________________________
> linux-arm-kernel mailing list
> linux-arm-kernel@...ts.infradead.org
> http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Powered by blists - more mailing lists