[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20220225215011.861477-1-mat.jonczyk@o2.pl>
Date: Fri, 25 Feb 2022 22:50:08 +0100
From: Mateusz Jończyk <mat.jonczyk@...pl>
To: linux-kernel@...r.kernel.org, linux-rtc@...r.kernel.org
Cc: Mateusz Jończyk <mat.jonczyk@...pl>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
Dave Hansen <dave.hansen@...ux.intel.com>, x86@...nel.org,
"H. Peter Anvin" <hpa@...or.com>,
Alessandro Zummo <a.zummo@...ertech.it>,
Alexandre Belloni <alexandre.belloni@...tlin.com>
Subject: [PATCH 0/3] rtc,x86: RTC CMOS refactoring
Hello,
The main aim of this series is to remove duplicated code in
mach_get_cmos_time() in arch/x86/kernel/rtc.c . This function performed
the same thing as mc146818_get_time() - reading the time from the CMOS
RTC - but used a different algorithm. So modify it to use standard
mc146818_get_time().
First, to make these functions more similar to each other (and also for
another reason described in the patch), reduce the polling period in
mc146818_get_time(). Then, rewrite mach_get_cmos_time().
The last patch renames a function in arch/x86/kernel/rtc.c.
I have tested this on three different computers.
Greetings,
Mateusz
Signed-off-by: Mateusz Jończyk <mat.jonczyk@...pl>
Cc: Thomas Gleixner <tglx@...utronix.de>
Cc: Ingo Molnar <mingo@...hat.com>
Cc: Borislav Petkov <bp@...en8.de>
Cc: Dave Hansen <dave.hansen@...ux.intel.com>
Cc: x86@...nel.org
Cc: "H. Peter Anvin" <hpa@...or.com>
Cc: Alessandro Zummo <a.zummo@...ertech.it>
Cc: Alexandre Belloni <alexandre.belloni@...tlin.com>
Mateusz Jończyk (3):
rtc-mc146818-lib: reduce RTC_UIP polling period
x86/rtc: rewrite mach_get_cmos_time
x86/rtc: rename mach_set_rtc_mmss
arch/x86/include/asm/mc146818rtc.h | 2 +-
arch/x86/kernel/rtc.c | 63 +++++-------------------------
arch/x86/kernel/x86_init.c | 2 +-
drivers/rtc/rtc-mc146818-lib.c | 8 ++--
4 files changed, 15 insertions(+), 60 deletions(-)
base-commit: cfb92440ee71adcc2105b0890bb01ac3cddb8507
--
2.25.1
Powered by blists - more mailing lists