[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20220303095245.00004396@Huawei.com>
Date: Thu, 3 Mar 2022 09:52:45 +0000
From: Jonathan Cameron <Jonathan.Cameron@...wei.com>
To: <cgel.zte@...il.com>
CC: <jic23@...nel.org>, <lars@...afoo.de>,
<tangbin@...s.chinamobile.com>, <linux-iio@...r.kernel.org>,
<linux-kernel@...r.kernel.org>,
Minghao Chi <chi.minghao@....com.cn>,
Zeal Robot <zealci@....com.cn>
Subject: Re: [PATCH] iio/adc: Use of_device_get_match_data()
On Thu, 3 Mar 2022 01:44:45 +0000
cgel.zte@...il.com wrote:
> From: Minghao Chi (CGEL ZTE) <chi.minghao@....com.cn>
>
> Use of_device_get_match_data() to simplify the code.
Hi
Thanks for the patch.
Please use the local naming convention for patches, so this should be:
iio: adc: twl6030: Use of_device_get_match_data()
However, we are in process of trying to move all of IIO over to generic
device properties (include/linux/properties.h) and so if we are going
to touch this driver, I'd like to see that change made.
Looks straight forwards with
device_get_match_data() being used here and dropping of_ specific headers
in favour of
linux/properties.h
linux/mod_devicetable.h
If you can make that change it would be great!
Thanks,
Jonathan
>
> Reported-by: Zeal Robot <zealci@....com.cn>
> Signed-off-by: Minghao Chi (CGEL ZTE) <chi.minghao@....com.cn>
> ---
> drivers/iio/adc/twl6030-gpadc.c | 7 +------
> 1 file changed, 1 insertion(+), 6 deletions(-)
>
> diff --git a/drivers/iio/adc/twl6030-gpadc.c b/drivers/iio/adc/twl6030-gpadc.c
> index afdb59e0b526..6a022e583658 100644
> --- a/drivers/iio/adc/twl6030-gpadc.c
> +++ b/drivers/iio/adc/twl6030-gpadc.c
> @@ -867,16 +867,11 @@ static int twl6030_gpadc_probe(struct platform_device *pdev)
> struct device *dev = &pdev->dev;
> struct twl6030_gpadc_data *gpadc;
> const struct twl6030_gpadc_platform_data *pdata;
> - const struct of_device_id *match;
> struct iio_dev *indio_dev;
> int irq;
> int ret;
>
> - match = of_match_device(of_twl6030_match_tbl, dev);
> - if (!match)
> - return -EINVAL;
> -
> - pdata = match->data;
> + pdata = of_device_get_match_data(dev);
>
> indio_dev = devm_iio_device_alloc(dev, sizeof(*gpadc));
> if (!indio_dev)
Powered by blists - more mailing lists