lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 7 Mar 2022 20:39:45 -0800
From:   Roman Gushchin <roman.gushchin@...ux.dev>
To:     Waiman Long <longman@...hat.com>
Cc:     Andrew Morton <akpm@...ux-foundation.org>, linux-mm@...ck.org,
        linux-kernel@...r.kernel.org,
        Muchun Song <songmuchun@...edance.com>
Subject: Re: [PATCH] mm/list_lru: Optimize memcg_drain_list_lru_node()

On Mon, Mar 07, 2022 at 10:30:09PM -0500, Waiman Long wrote:
> Since commit 2c80cd57c743 ("mm/list_lru.c: fix list_lru_count_node()
> to be race free"), we are tracking the total number of lru
> entries in a list_lru_node in its nr_items field.  In the case of
> memcg_drain_list_lru_node(), there is nothing to be done if nr_items
> is 0.  We don't even need to take the nlru->lock as no new lru entry
> could be added by a racing list_lru_add() to the draining src_idx memcg
> at this point.
> 
> Signed-off-by: Waiman Long <longman@...hat.com>

Hi Waiman!

The patch makes total sense to me, however it needs to be rebased at least
on top of "mm: list_lru: rename memcg_drain_all_list_lrus to memcg_reparent_list_lrus".

Thanks!


> ---
>  mm/list_lru.c | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/mm/list_lru.c b/mm/list_lru.c
> index 0cd5e89ca063..100ca453e885 100644
> --- a/mm/list_lru.c
> +++ b/mm/list_lru.c
> @@ -518,6 +518,12 @@ static void memcg_drain_list_lru_node(struct list_lru *lru, int nid,
>  	int dst_idx = dst_memcg->kmemcg_id;
>  	struct list_lru_one *src, *dst;
>  
> +	/*
> +	 * If there is no lru entry in this nlru, we can skip it immediately.
> +	 */
> +	if (!READ_ONCE(nlru->nr_items))
> +		return;
> +
>  	/*
>  	 * Since list_lru_{add,del} may be called under an IRQ-safe lock,
>  	 * we have to use IRQ-safe primitives here to avoid deadlock.
> -- 
> 2.27.0
> 
> 

Powered by blists - more mailing lists