[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <7496e04f-5b34-b37c-381c-8444199f2321@redhat.com>
Date: Fri, 11 Mar 2022 10:55:45 +0100
From: David Hildenbrand <david@...hat.com>
To: Miaohe Lin <linmiaohe@...wei.com>, akpm@...ux-foundation.org
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mm/madvise: Use vma_lookup() instead of find_vma()
On 11.03.22 09:27, Miaohe Lin wrote:
> Using vma_lookup() verifies the start address is contained in the found
> vma. This results in easier to read the code.
>
> Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
> ---
> mm/madvise.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/mm/madvise.c b/mm/madvise.c
> index 5b6d796e55de..afd68bfc77d4 100644
> --- a/mm/madvise.c
> +++ b/mm/madvise.c
> @@ -883,8 +883,8 @@ static long madvise_populate(struct vm_area_struct *vma,
> * our VMA might have been split.
> */
> if (!vma || start >= vma->vm_end) {
> - vma = find_vma(mm, start);
> - if (!vma || start < vma->vm_start)
> + vma = vma_lookup(mm, start);
> + if (!vma)
> return -ENOMEM;
> }
>
Reviewed-by: David Hildenbrand <david@...hat.com>
--
Thanks,
David / dhildenb
Powered by blists - more mailing lists