[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <650c667f-ca55-821d-4e0f-29fce69a68fc@huawei.com>
Date: Wed, 16 Mar 2022 08:23:34 +0000
From: John Garry <john.garry@...wei.com>
To: Damien Le Moal <damien.lemoal@...nsource.wdc.com>,
<jejb@...ux.ibm.com>, <martin.petersen@...cle.com>,
<bvanassche@....org>, <ming.lei@...hat.com>, <hch@....de>,
<hare@...e.de>
CC: <linux-ide@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
<linux-scsi@...r.kernel.org>, <martin.wilck@...e.com>
Subject: Re: [PATCH RFC 2/2] libata: Use scsi cmnd budget token for qc tag for
SAS host
Hi Damien,
>> - }
>> - return -1;
>> + return scmd->budget_token;
>> }
> Since this is now not actually allocating a tag, I would rename this
> something like ata_sas_get_tag(). Or even better, simply open code this
> in ata_qc_new_init() since that is the only caller.
ok, I think it might be better to open code in ata_qc_new_init(), as
suggested. That should avoid the need for the return -1 call.
>
>>
>> void ata_sas_free_tag(unsigned int tag, struct ata_port *ap)
>> {
>> - clear_bit(tag, &ap->sas_tag_allocated);
>> }
> This is called only in ata_qc_free(). With this change, the function is
> empty, so let's completely remove it.
>
ok
>>
>> /**
>> diff --git a/drivers/ata/libata-scsi.c b/drivers/ata/libata-scsi.c
>> index ed8be585a98f..45d63a2ba3ee 100644
>> --- a/drivers/ata/libata-scsi.c
>> +++ b/drivers/ata/libata-scsi.c
>> @@ -640,7 +640,7 @@ static struct ata_queued_cmd *ata_scsi_qc_new(struct ata_device *dev,
>> {
Thanks,
John
Powered by blists - more mailing lists