[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHk-=wibzB9fSXZf79FhjAvoLsPP0YG4VKjQy0jZE8BZj8uBOg@mail.gmail.com>
Date: Thu, 17 Mar 2022 18:50:46 -0700
From: Linus Torvalds <torvalds@...ux-foundation.org>
To: Segher Boessenkool <segher@...nel.crashing.org>
Cc: Florian Weimer <fweimer@...hat.com>,
Nick Desaulniers <ndesaulniers@...gle.com>,
"H. Peter Anvin" <hpa@...or.com>, Bill Wendling <morbo@...gle.com>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
Dave Hansen <dave.hansen@...ux.intel.com>,
"maintainer:X86 ARCHITECTURE (32-BIT AND 64-BIT)" <x86@...nel.org>,
Nathan Chancellor <nathan@...nel.org>,
Juergen Gross <jgross@...e.com>,
Peter Zijlstra <peterz@...radead.org>,
Andy Lutomirski <luto@...nel.org>, llvm@...ts.linux.dev,
LKML <linux-kernel@...r.kernel.org>,
linux-toolchains <linux-toolchains@...r.kernel.org>
Subject: Re: [PATCH v5] x86: use builtins to read eflags
On Thu, Mar 17, 2022 at 6:21 PM Linus Torvalds
<torvalds@...ux-foundation.org> wrote:
>
> Now, compare that to just using inline asm: it's trivial, and we've
> used it basically unchanged for three decades.
Ok, so going _really_ far back, we used to have them literally written out:
__asm__ __volatile__("pushfl ; popl %0 ; cli":"=r" (flags));
in random code, and then in October 1992 switched those nasty things
to instead use
#define cli() __asm__ __volatile__ ("cli"::)
#define save_flags(x) \
__asm__ __volatile__("pushfl ; popl %0":"=r" (x))
and the code was changed to actually use
save_flags(flags);
cli();
instead of that open-coded raw asm.
And the "memory" clobber was added early June, 1993:
#define save_flags(x) \
-__asm__ __volatile__("pushfl ; popl %0":"=r" (x))
+__asm__ __volatile__("pushfl ; popl %0":"=r" (x)::"memory")
so that thing really has existed in pretty much that exact form for
almost 30 years.
There's been tweaks since (the "=r" became "=g" before becoming "=rm",
comments have been added, "pushfl" became just "pushf" with x86-64,
and the thing has moved around and is now called "native_save_fl()" in
a completely different header file etc)
But at no point was it ever as buggy as the actual gcc intrinsic seems
to be today, nor have we needed to check for compiler versions etc.
Linus
Powered by blists - more mailing lists