lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 23 Mar 2022 13:37:32 +0100
From:   Andrew Lunn <andrew@...n.ch>
To:     ryan_chen <ryan_chen@...eedtech.com>
Cc:     BMC-SW@...eedtech.com, Rob Herring <robh+dt@...nel.org>,
        Joel Stanley <joel@....id.au>,
        Andrew Jeffery <andrew@...id.au>,
        Philipp Zabel <p.zabel@...gutronix.de>,
        linux-arm-kernel@...ts.infradead.org,
        linux-aspeed@...ts.ozlabs.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/2] i2c:aspeed:support ast2600 i2c new register mode
 driver

On Wed, Mar 23, 2022 at 08:40:09AM +0800, ryan_chen wrote:
> Add i2c new register mode driver to support AST2600 i2c
> new register set. AST2600 i2c controller have legacy and
> new register mode. The new register mode have global register
> support 4 base clock for scl clock selection, and new clock
> divider mode. And i2c new register mode have separate register
> set to control i2c master and slave.
> 
> Signed-off-by: Ryan Chen <ryan_chen@...eedtech.com>
> ---
>  drivers/i2c/busses/Kconfig                 |   11 +
>  drivers/i2c/busses/Makefile                |    1 +
>  drivers/i2c/busses/aspeed-i2c-new-global.c |   91 ++
>  drivers/i2c/busses/aspeed-i2c-new-global.h |   19 +
>  drivers/i2c/busses/i2c-new-aspeed.c        | 1698 ++++++++++++++++++++

I always find it funny when somebody uses 'new'. What is the next
version going to be called? 'even-newer', and the version after that
'really-really-new'?

> +static const struct of_device_id aspeed_new_i2c_bus_of_table[] = {
> +	{
> +		.compatible = "aspeed,ast2600-i2c-bus",
> +	},

Given this compatible string, why not call it i2c-aspeed-2600.c, and
remove 'new' everywhere.

       Andrew

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ