[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <0c830e36-fcf2-fab6-aed9-7b6a6736140f@redhat.com>
Date: Thu, 31 Mar 2022 11:34:35 +0200
From: Paolo Bonzini <pbonzini@...hat.com>
To: David Matlack <dmatlack@...gle.com>
Cc: linux-kernel@...r.kernel.org, kvm@...r.kernel.org
Subject: Re: [PATCH] KVM: MMU: propagate alloc_workqueue failure
On 3/31/22 01:51, David Matlack wrote:
>> -void kvm_mmu_init_vm(struct kvm *kvm)
>> +int kvm_mmu_init_vm(struct kvm *kvm)
>> {
>> struct kvm_page_track_notifier_node *node = &kvm->arch.mmu_sp_tracker;
>> + int r;
>>
>> + INIT_LIST_HEAD(&kvm->arch.active_mmu_pages);
>> + INIT_LIST_HEAD(&kvm->arch.zapped_obsolete_pages);
>> + INIT_LIST_HEAD(&kvm->arch.lpage_disallowed_mmu_pages);
>
> I agree with moving these but that should probably be done in a separate
> commit.
Ok.
>> - kvm->arch.tdp_mmu_zap_wq =
>> - alloc_workqueue("kvm", WQ_UNBOUND|WQ_MEM_RECLAIM|WQ_CPU_INTENSIVE, 0);
>> -
>> - return true;
>> + kvm->arch.tdp_mmu_zap_wq = wq;
>
> Suggest moving this to just after checking the return value of
> alloc_workqueue().
This is intentional, in case we have other future allocations, to avoid
having to NULL out the field in the unwind path. It's a matter of taste
I guess.
>> + return 1;
>
> Perhaps return 0 until we have a reason to differentiate the 2 cases.
Yeah, though I wanted to preserve the previous behavior.
>> diff --git a/arch/x86/kvm/x86.c b/arch/x86/kvm/x86.c
>> index fe2171b11441..89b6efb7f504 100644
>> --- a/arch/x86/kvm/x86.c
>> +++ b/arch/x86/kvm/x86.c
>> @@ -11629,12 +11629,13 @@ int kvm_arch_init_vm(struct kvm *kvm, unsigned long type)
>>
>> ret = kvm_page_track_init(kvm);
>> if (ret)
>> - return ret;
>> + goto out;
>
> nit: This goto is unnecessary.
True, but I prefer to be consistent in using "goto" so that any future
additions are careful about preserving the chain.
Paolo
Powered by blists - more mailing lists