[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <23fbc97f-05e9-2609-46cc-4320ddc9df12@intel.com>
Date: Sat, 2 Apr 2022 20:47:20 +0800
From: Zeng Guang <guang.zeng@...el.com>
To: Sean Christopherson <seanjc@...gle.com>
Cc: Paolo Bonzini <pbonzini@...hat.com>,
Vitaly Kuznetsov <vkuznets@...hat.com>,
Wanpeng Li <wanpengli@...cent.com>,
Jim Mattson <jmattson@...gle.com>,
Joerg Roedel <joro@...tes.org>,
"kvm@...r.kernel.org" <kvm@...r.kernel.org>,
Dave Hansen <dave.hansen@...ux.intel.com>,
"Luck, Tony" <tony.luck@...el.com>,
Kan Liang <kan.liang@...ux.intel.com>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
"H. Peter Anvin" <hpa@...or.com>,
Kim Phillips <kim.phillips@....com>,
Jarkko Sakkinen <jarkko@...nel.org>,
Jethro Beekman <jethro@...tanix.com>,
"Huang, Kai" <kai.huang@...el.com>,
"x86@...nel.org" <x86@...nel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"Hu, Robert" <robert.hu@...el.com>,
"Gao, Chao" <chao.gao@...el.com>,
Robert Hoo <robert.hu@...ux.intel.com>
Subject: Re: [PATCH v7 2/8] KVM: VMX: Extend BUILD_CONTROLS_SHADOW macro to
support 64-bit variation
On 4/1/2022 6:27 AM, Sean Christopherson wrote:
> On Fri, Mar 04, 2022, Zeng Guang wrote:
>> +#define BUILD_CONTROLS_SHADOW(lname, uname, bits) \
>> +static inline \
>> +void lname##_controls_set(struct vcpu_vmx *vmx, u##bits val) \
>> +{ \
>> + if (vmx->loaded_vmcs->controls_shadow.lname != val) { \
>> + vmcs_write##bits(uname, val); \
>> + vmx->loaded_vmcs->controls_shadow.lname = val; \
>> + } \
>> +} \
>> +static inline u##bits __##lname##_controls_get(struct loaded_vmcs *vmcs)\
>> +{ \
>> + return vmcs->controls_shadow.lname; \
>> +} \
>> +static inline u##bits lname##_controls_get(struct vcpu_vmx *vmx) \
>> +{ \
>> + return __##lname##_controls_get(vmx->loaded_vmcs); \
>> +} \
>> +static inline \
> Drop the newline, there's no need to split this across two lines. Aligning the
> backslashes will mean they all poke past the 80 char soft limit, but that's totally
> ok. The whole point of the line limit is to improve readability, and a trivial
> runover is much less painful than a split function declaration. As a bonus, all
> the backslashes are aligned, have leading whitespace, and still land on a tab stop :-)
>
> #define BUILD_CONTROLS_SHADOW(lname, uname, bits) \
> static inline void lname##_controls_set(struct vcpu_vmx *vmx, u##bits val) \
> { \
> if (vmx->loaded_vmcs->controls_shadow.lname != val) { \
> vmcs_write##bits(uname, val); \
> vmx->loaded_vmcs->controls_shadow.lname = val; \
> } \
> } \
> static inline u##bits __##lname##_controls_get(struct loaded_vmcs *vmcs) \
> { \
> return vmcs->controls_shadow.lname; \
> } \
> static inline u##bits lname##_controls_get(struct vcpu_vmx *vmx) \
> { \
> return __##lname##_controls_get(vmx->loaded_vmcs); \
> } \
> static inline void lname##_controls_setbit(struct vcpu_vmx *vmx, u##bits val) \
> { \
> lname##_controls_set(vmx, lname##_controls_get(vmx) | val); \
> } \
> static inline void lname##_controls_clearbit(struct vcpu_vmx *vmx, u##bits val) \
> { \
> lname##_controls_set(vmx, lname##_controls_get(vmx) & ~val); \
> }
>
> With that fixed,
>
> Reviewed-by: Sean Christopherson <seanjc@...gle.com>
OK. I'll revise it.
Powered by blists - more mailing lists