[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Yk0fbUs584vRprMg@infradead.org>
Date: Tue, 5 Apr 2022 22:04:45 -0700
From: Christoph Hellwig <hch@...radead.org>
To: Jane Chu <jane.chu@...cle.com>
Cc: david@...morbit.com, djwong@...nel.org, dan.j.williams@...el.com,
hch@...radead.org, vishal.l.verma@...el.com, dave.jiang@...el.com,
agk@...hat.com, snitzer@...hat.com, dm-devel@...hat.com,
ira.weiny@...el.com, willy@...radead.org, vgoyal@...hat.com,
linux-fsdevel@...r.kernel.org, nvdimm@...ts.linux.dev,
linux-kernel@...r.kernel.org, linux-xfs@...r.kernel.org,
x86@...nel.org
Subject: Re: [PATCH v7 5/6] pmem: refactor pmem_clear_poison()
On Tue, Apr 05, 2022 at 01:47:46PM -0600, Jane Chu wrote:
> + pmem_clear_bb(pmem, to_sect(pmem, offset), cleared >> SECTOR_SHIFT);
> + return (cleared < len) ? BLK_STS_IOERR : BLK_STS_OK;
No need for the braces. That being said perosnally I find a simple:
if (cleared < len)
return BLK_STS_IOERR;
return BLK_STS_OK;
much easier to read anyway.
Otherwise looks good:
Reviewed-by: Christoph Hellwig <hch@....de>
Powered by blists - more mailing lists