lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <19e11d77-1f81-c5a8-8a72-4fb7616438bf@kernel.org>
Date:   Wed, 6 Apr 2022 11:57:12 +0200
From:   Jiri Slaby <jirislaby@...nel.org>
To:     wujunwen <wudaemon@....com>, gregkh@...uxfoundation.org
Cc:     linux-kernel@...r.kernel.org
Subject: Re: [PATCH v1] tty/sysrq: change the definition of sysrq_key_table's
 element to make it more readable

Hi,

On 05. 04. 22, 17:36, wujunwen wrote:
> the definition of sysrq_key_table's elements, like sysrq_thaw_op and

The starts the sentence, so should be with capital T.

> sysrq_showallcpus_op are massive,

massive?

> so we should make it consistent.

You should elaborate consistent to what.

> Signed-off-by: wujunwen <wudaemon@....com>

Is this really your real full name?

Other than that, the patch appears to be correct.

>   drivers/tty/sysrq.c | 14 ++++++--------
>   1 file changed, 6 insertions(+), 8 deletions(-)
> 
> diff --git a/drivers/tty/sysrq.c b/drivers/tty/sysrq.c
> index bbfd004449b5..9485156bf48b 100644
> --- a/drivers/tty/sysrq.c
> +++ b/drivers/tty/sysrq.c
> @@ -274,6 +274,8 @@ static const struct sysrq_key_op sysrq_showallcpus_op = {
>   	.action_msg	= "Show backtrace of all active CPUs",
>   	.enable_mask	= SYSRQ_ENABLE_DUMP,
>   };
> +#else
> +#define sysrq_showallcpus_op (*(const struct sysrq_key_op *)NULL)
>   #endif
>   
>   static void sysrq_handle_showregs(int key)
> @@ -405,6 +407,7 @@ static const struct sysrq_key_op sysrq_moom_op = {
>   	.enable_mask	= SYSRQ_ENABLE_SIGNAL,
>   };
>   
> +#ifdef CONFIG_BLOCK
>   static void sysrq_handle_thaw(int key)
>   {
>   	emergency_thaw_all();
> @@ -415,6 +418,9 @@ static const struct sysrq_key_op sysrq_thaw_op = {
>   	.action_msg	= "Emergency Thaw of all frozen filesystems",
>   	.enable_mask	= SYSRQ_ENABLE_SIGNAL,
>   };
> +#else
> +#define sysrq_thaw_op (*(const struct sysrq_key_op *)NULL)
> +#endif
>   
>   static void sysrq_handle_kill(int key)
>   {
> @@ -468,17 +474,9 @@ static const struct sysrq_key_op *sysrq_key_table[62] = {
>   	NULL,				/* g */
>   	NULL,				/* h - reserved for help */
>   	&sysrq_kill_op,			/* i */
> -#ifdef CONFIG_BLOCK
>   	&sysrq_thaw_op,			/* j */
> -#else
> -	NULL,				/* j */
> -#endif
>   	&sysrq_SAK_op,			/* k */
> -#ifdef CONFIG_SMP
>   	&sysrq_showallcpus_op,		/* l */
> -#else
> -	NULL,				/* l */
> -#endif
>   	&sysrq_showmem_op,		/* m */
>   	&sysrq_unrt_op,			/* n */
>   	/* o: This will often be registered as 'Off' at init time */


-- 
js
suse labs

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ