lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Thu,  7 Apr 2022 17:18:21 +0200
From:   Stephen Kitt <steve@....org>
To:     Michael Turquette <mturquette@...libre.com>,
        Stephen Boyd <sboyd@...nel.org>
Cc:     linux-clk@...r.kernel.org, linux-kernel@...r.kernel.org,
        Wolfram Sang <wsa@...nel.org>, Stephen Kitt <steve@....org>
Subject: [PATCH v2 00/10] clk: switch to simple i2c probe function

This series of patches updates i2c probes in clk to use the simple
probe variant (simple as in "single argument"), probe_new, following
one of two scenarios.

In the first scenario, the existing probe function

int (*probe)(struct i2c_client *client, const struct i2c_device_id *id);

(see struct i2c_driver in include/linux/i2c.h) doesn't use the id
argument, so it can be trivially converted to

int (*probe_new)(struct i2c_client *client);

and the i2c_driver declaration updated to use .probe_new instead of
.probe.

In the second scenario, the probe function does use the id argument.
In this case, the relevant part of the calling code,

        /*
         * When there are no more users of probe(),
         * rename probe_new to probe.
         */
        if (driver->probe_new)
                status = driver->probe_new(client);
        else if (driver->probe)
                status = driver->probe(client,
                                       i2c_match_id(driver->id_table, client));
        else
                status = -EINVAL;

(from drivers/i2c/i2c-core-base.c) is moved down into the probe
function, typically along the lines of

const struct i2c_device_id *id = i2c_match_id(ids, id);

where ids is the i2c_device_id table. The latter needs to be declared
before the probe function; as suggested by Wolfram Sang, the full
definition is moved above the probe function.

Changes since v1:
  - the pair of patches have been split up into a single patch series
    with one patch per modified file, and the commit titles adjusted
    accordingly
  - renesas-pcie has been added


Stephen Kitt (10):
  clk: cdce706: use simple i2c probe function
  clk: cdce925: use i2c_match_id and simple i2c probe
  clk: cs2000-cp: use simple i2c probe function
  clk: max9485: use simple i2c probe function
  clk: si514: use simple i2c probe function
  clk: si5341: use simple i2c probe function
  clk: si5351: use i2c_match_id and simple i2c probe
  clk: si544: use i2c_match_id and simple i2c probe
  clk: si570: use i2c_match_id and simple i2c probe
  clk: renesas-pcie: use simple i2c probe function

 drivers/clk/clk-cdce706.c      |  5 ++---
 drivers/clk/clk-cdce925.c      | 24 ++++++++++++------------
 drivers/clk/clk-cs2000-cp.c    |  5 ++---
 drivers/clk/clk-max9485.c      |  5 ++---
 drivers/clk/clk-renesas-pcie.c |  4 ++--
 drivers/clk/clk-si514.c        |  5 ++---
 drivers/clk/clk-si5341.c       |  5 ++---
 drivers/clk/clk-si5351.c       | 24 ++++++++++++------------
 drivers/clk/clk-si544.c        | 22 +++++++++++-----------
 drivers/clk/clk-si570.c        | 24 ++++++++++++------------
 10 files changed, 59 insertions(+), 64 deletions(-)

-- 
2.27.0

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ