[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <Yk/Dmy7PYqn532M+@kroah.com>
Date: Fri, 8 Apr 2022 07:09:47 +0200
From: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
To: Julia Lawall <julia.lawall@...ia.fr>
Cc: Rebecca Mckeever <remckee0@...il.com>, outreachy@...ts.linux.dev,
linux-staging@...ts.linux.dev, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 1/2] staging: rtl8192u: replace ternary statement with
if and assignment
On Fri, Apr 08, 2022 at 06:15:14AM +0200, Julia Lawall wrote:
>
>
> On Thu, 7 Apr 2022, Rebecca Mckeever wrote:
>
> > Replace ternary statement with an if statement followed by an assignment
> > to increase readability and make error handling more obvious.
> > Found with minmax coccinelle script.
> >
> > Signed-off-by: Rebecca Mckeever <remckee0@...il.com>
> > ---
> > drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c | 4 +++-
> > 1 file changed, 3 insertions(+), 1 deletion(-)
> >
> > diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c b/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c
> > index 78cc8f357bbc..9885917b9199 100644
> > --- a/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c
> > +++ b/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c
> > @@ -470,7 +470,9 @@ int ieee80211_wx_get_encode(struct ieee80211_device *ieee,
> > return 0;
> > }
> > len = crypt->ops->get_key(keybuf, SCM_KEY_LEN, NULL, crypt->priv);
> > - erq->length = (len >= 0 ? len : 0);
> > + if (len < 0)
> > + len = 0;
> > + erq->length = len;
>
> Maybe you could use max here?
Dan said to not do this on based on the first submission :)
Powered by blists - more mailing lists