[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e1e0a871d1a991980ffc9afe7198775b27833f6d.camel@perches.com>
Date: Fri, 08 Apr 2022 00:19:01 -0700
From: Joe Perches <joe@...ches.com>
To: Dan Carpenter <dan.carpenter@...cle.com>
Cc: Julia Lawall <julia.lawall@...ia.fr>,
Rebecca Mckeever <remckee0@...il.com>,
outreachy@...ts.linux.dev,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
linux-staging@...ts.linux.dev, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 1/2] staging: rtl8192u: replace ternary statement
with if and assignment
On Fri, 2022-04-08 at 09:31 +0300, Dan Carpenter wrote:
> On Thu, Apr 07, 2022 at 11:14:51PM -0700, Joe Perches wrote:
> > On Fri, 2022-04-08 at 08:57 +0300, Dan Carpenter wrote:
> > > On Fri, Apr 08, 2022 at 06:15:14AM +0200, Julia Lawall wrote:
> > > > On Thu, 7 Apr 2022, Rebecca Mckeever wrote:
> > > >
> > > > > Replace ternary statement with an if statement followed by an assignment
> > > > > to increase readability and make error handling more obvious.
> > > > > Found with minmax coccinelle script.
> > []
> > > > > diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c b/drivers/staging/rtl8192u/ieee80211/ieee80211_wx.c
> > []
> > > > > @@ -470,7 +470,9 @@ int ieee80211_wx_get_encode(struct ieee80211_device *ieee,
> > > > > return 0;
> > > > > }
> > > > > len = crypt->ops->get_key(keybuf, SCM_KEY_LEN, NULL, crypt->priv);
> > > > > - erq->length = (len >= 0 ? len : 0);
> > > > > + if (len < 0)
> > > > > + len = 0;
> > > > > + erq->length = len;
> > > >
> > > > Maybe you could use max here?
> > >
> > > Initially Rebecca did use max() but I NAKed it. It's really not less
> > > readable. Better to handle the error explicitly. Keep the error path
> > > indented two tabs. Separate from the success path.
> >
> > A comment would be useful as it's not obvious it's an 'error' path.
> > One has to read all 3 get_key functions to determine that.
> >
>
> I'm so confused. Negative error codes are the common case in the
> kernel. We don't need to comment it.
If it was an error, it would handle it as an error not set
len to 0 and continue. That's why IMO a comment is useful.
Powered by blists - more mailing lists