lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Tue, 12 Apr 2022 13:02:17 +0200
From:   Jakob Koschel <jakobkoschel@...il.com>
To:     Chao Yu <chao@...nel.org>
Cc:     Jaegeuk Kim <jaegeuk@...nel.org>,
        Linux F2FS Dev Mailing List 
        <linux-f2fs-devel@...ts.sourceforge.net>,
        LKML <linux-kernel@...r.kernel.org>,
        Mike Rapoport <rppt@...nel.org>,
        Brian Johannesmeyer <bjohannesmeyer@...il.com>,
        Cristiano Giuffrida <c.giuffrida@...nl>,
        "Bos, H.J." <h.j.bos@...nl>
Subject: Re: [PATCH 1/2] f2fs: use separate list iterator variable to call
 list_move_tail()



> On 12. Apr 2022, at 11:40, Chao Yu <chao@...nel.org> wrote:
> 
> On 2022/4/1 6:16, Jakob Koschel wrote:
>> In preparation to limit the scope of a list iterator to the list
>> traversal loop, use a dedicated pointer to point to the found element
>> [1].
>> If no break is hit or the list is empty, 'next' will be NULL and
>> list_move_tail() should be called explicitly on the head directly.
>> Link: https://lore.kernel.org/all/CAHk-=wgRr_D8CB-D9Kg-c=EHreAsk5SqXPwr9Y7k9sA6cWXJ6w@mail.gmail.com/
>> Signed-off-by: Jakob Koschel <jakobkoschel@...il.com>
>> ---
>> fs/f2fs/segment.c | 12 ++++++++----
>> 1 file changed, 8 insertions(+), 4 deletions(-)
>> diff --git a/fs/f2fs/segment.c b/fs/f2fs/segment.c
>> index 22dfeb991529..81ef2c3d08e5 100644
>> --- a/fs/f2fs/segment.c
>> +++ b/fs/f2fs/segment.c
>> @@ -4175,16 +4175,20 @@ static void release_sit_entry_set(struct sit_entry_set *ses)
>> static void adjust_sit_entry_set(struct sit_entry_set *ses,
>> 						struct list_head *head)
>> {
>> -	struct sit_entry_set *next = ses;
>> +	struct sit_entry_set *next = NULL, *iter = ses;
>> 	if (list_is_last(&ses->set_list, head))
>> 		return;
>> -	list_for_each_entry_continue(next, head, set_list)
>> -		if (ses->entry_cnt <= next->entry_cnt)
>> +	list_for_each_entry_continue(iter, head, set_list)
>> +		if (ses->entry_cnt <= iter->entry_cnt) {
>> +			next = iter;
>> +			list_move_tail(&ses->set_list, &iter->set_list);
>> 			break;
> 
> return;
> 
>> +		}
>> -	list_move_tail(&ses->set_list, &next->set_list);
>> +	if (!next)
>> +		list_move_tail(&ses->set_list, head);
> 
> list_move_tail(&ses->set_list, head);
> 
> Then we don't need @next variable, right?

Of course yes, good spot! I'll fix and resend a v2 in the next days.
Thanks for the input.

> 
> Thanks,
> 
>> }
>> static void add_sit_entry(unsigned int segno, struct list_head *head)
>> base-commit: d888c83fcec75194a8a48ccd283953bdba7b2550

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ