lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 13 Apr 2022 16:46:20 +0200
From:   "Rafael J. Wysocki" <rafael@...nel.org>
To:     Yang Li <yang.lee@...ux.alibaba.com>
Cc:     "Rafael J. Wysocki" <rafael@...nel.org>,
        Pavel Machek <pavel@....cz>, Len Brown <len.brown@...el.com>,
        Linux PM <linux-pm@...r.kernel.org>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
        Abaci Robot <abaci@...ux.alibaba.com>
Subject: Re: [PATCH -next] kernel/power: Fix some kernel-doc comments

On Fri, Mar 25, 2022 at 2:44 AM Yang Li <yang.lee@...ux.alibaba.com> wrote:
>
> Add parameter description in alloc_rtree_node()  kernel-doc
> comment and fix several inconsistent function name descriptions.
>
> Remove some warnings found by running scripts/kernel-doc,
> which is caused by using 'make W=1'.
>
> kernel/power/snapshot.c:438: warning: Function parameter or member
> 'gfp_mask' not described in 'alloc_rtree_node'
> kernel/power/snapshot.c:438: warning: Function parameter or member
> 'safe_needed' not described in 'alloc_rtree_node'
> kernel/power/snapshot.c:438: warning: Function parameter or member 'ca'
> not described in 'alloc_rtree_node'
> kernel/power/snapshot.c:438: warning: Function parameter or member
> 'list' not described in 'alloc_rtree_node'
> kernel/power/snapshot.c:916: warning: expecting prototype for
> memory_bm_rtree_next_pfn(). Prototype was for memory_bm_next_pfn()
> instead
> kernel/power/snapshot.c:1947: warning: expecting prototype for
> alloc_highmem_image_pages(). Prototype was for alloc_highmem_pages()
> instead
> kernel/power/snapshot.c:2230: warning: expecting prototype for load
> header(). Prototype was for load_header() instead
>
> Reported-by: Abaci Robot <abaci@...ux.alibaba.com>
> Signed-off-by: Yang Li <yang.lee@...ux.alibaba.com>
> ---
>  kernel/power/snapshot.c | 12 +++++++++---
>  1 file changed, 9 insertions(+), 3 deletions(-)
>
> diff --git a/kernel/power/snapshot.c b/kernel/power/snapshot.c
> index 330d49937692..89c8f9df9fdc 100644
> --- a/kernel/power/snapshot.c
> +++ b/kernel/power/snapshot.c
> @@ -427,6 +427,12 @@ struct memory_bitmap {
>
>  /**
>   * alloc_rtree_node - Allocate a new node and add it to the radix tree.
> + * @gfp_mask: GFP mask for the allocation.
> + * @safe_needed: Get pages that were not used before hibernation
> + *              (restore only)
> + * @ca: used for allocating small objects out of a linked list of pages
> + *     called 'the chain'.
> + * @list: the inner node or leave of Radix Tree to add.
>   *
>   * This function is used to allocate inner nodes as well as the
>   * leave nodes of the radix tree. It also adds the node to the
> @@ -902,7 +908,7 @@ static bool rtree_next_node(struct memory_bitmap *bm)
>  }
>
>  /**
> - * memory_bm_rtree_next_pfn - Find the next set bit in a memory bitmap.
> + * memory_bm_next_pfn - Find the next set bit in a memory bitmap.
>   * @bm: Memory bitmap.
>   *
>   * Starting from the last returned position this function searches for the next
> @@ -1937,7 +1943,7 @@ static inline int get_highmem_buffer(int safe_needed)
>  }
>
>  /**
> - * alloc_highmem_image_pages - Allocate some highmem pages for the image.
> + * alloc_highmem_pages - Allocate some highmem pages for the image.
>   *
>   * Try to allocate as many pages as needed, but if the number of free highmem
>   * pages is less than that, allocate them all.
> @@ -2224,7 +2230,7 @@ static int check_header(struct swsusp_info *info)
>  }
>
>  /**
> - * load header - Check the image header and copy the data from it.
> + * load_header - Check the image header and copy the data from it.
>   */
>  static int load_header(struct swsusp_info *info)
>  {
> --

Applied as 5.19 with edits in the subject and some comment adjustments
to avoid line breaks in kerne-doc.

Thanks!

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ