[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20220420222505.928492-1-frowand.list@gmail.com>
Date: Wed, 20 Apr 2022 17:25:03 -0500
From: frowand.list@...il.com
To: Rob Herring <robh+dt@...nel.org>, pantelis.antoniou@...sulko.com,
Slawomir Stepien <slawomir.stepien@...ia.com>
Cc: devicetree@...r.kernel.org, linux-kernel@...r.kernel.org,
Slawomir Stepien <sst@...zta.fm>,
Jan Kiszka <jan.kiszka@...mens.com>,
Geert Uytterhoeven <geert+renesas@...der.be>
Subject: [PATCH v4 0/2] of: overlay: rework overlay apply and remove kfree()s
From: Frank Rowand <frank.rowand@...y.com>
Fix various kfree() issues related to of_overlay_apply().
The fixes revealed inconsist variable names for the same variable
across functions, resulting in difficulty understanding the code
that was being modified. Doing both variable renaming and the
fixes results in a hard to review patch, so split into two patches.
The first patch in the series contains only variable renaming.
The second patch contains the kfree() related fixes.
version 4:
- patch 2/2 updated, changelogs in patch
version 3:
- All patches updated, changelogs in each patch
version 2:
- patch 1/2 new
- patch 2/2 updated, changelogs in patch
Frank Rowand (2):
of: overlay: rename variables to be consistent
of: overlay: rework overlay apply and remove kfree()s
Documentation/devicetree/overlay-notes.rst | 30 ++-
drivers/of/overlay.c | 283 ++++++++++-----------
include/linux/of.h | 3 +-
3 files changed, 163 insertions(+), 153 deletions(-)
--
Frank Rowand <frank.rowand@...y.com>
Powered by blists - more mailing lists