[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <Yl+948unOoDFdLe2@hovoldconsulting.com>
Date: Wed, 20 Apr 2022 10:01:39 +0200
From: Johan Hovold <johan@...nel.org>
To: cgel.zte@...il.com
Cc: elder@...nel.org, gregkh@...uxfoundation.org,
greybus-dev@...ts.linaro.org, linux-kernel@...r.kernel.org,
Minghao Chi <chi.minghao@....com.cn>,
Zeal Robot <zealci@....com.cn>
Subject: Re: [PATCH] greybus: using pm_runtime_resume_and_get to simplify the
code
On Wed, Apr 20, 2022 at 03:06:58AM +0000, cgel.zte@...il.com wrote:
> From: Minghao Chi <chi.minghao@....com.cn>
Why are you sending patches from a random non-personal gmail address?
> Using pm_runtime_resume_and_get() to replace pm_runtime_get_sync and
> pm_runtime_put_noidle. This change is just to simplify the code, no
> actual functional changes.
>
> Reported-by: Zeal Robot <zealci@....com.cn>
And why is this here?
> Signed-off-by: Minghao Chi <chi.minghao@....com.cn>
> ---
> drivers/greybus/core.c | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/greybus/core.c b/drivers/greybus/core.c
> index e546c6431877..434aa5d9dd47 100644
> --- a/drivers/greybus/core.c
> +++ b/drivers/greybus/core.c
> @@ -174,11 +174,9 @@ static int greybus_probe(struct device *dev)
> if (!id)
> return -ENODEV;
>
> - retval = pm_runtime_get_sync(&bundle->intf->dev);
> - if (retval < 0) {
> - pm_runtime_put_noidle(&bundle->intf->dev);
> + retval = pm_runtime_resume_and_get(&bundle->intf->dev);
> + if (retval < 0)
> return retval;
> - }
NAK.
Greybus is using the pm_runtime_get_sync() consistently and mixing it up
with the new helper that uses a different naming scheme is just
confusing.
Use the new helper for your own code if you prefer, but there's really
no need to go around submitting this automatic conversions for code
that's already in the tree.
> retval = gb_control_bundle_activate(bundle->intf->control, bundle->id);
> if (retval) {
Johan
Powered by blists - more mailing lists