[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <Yl/CenHPSSXZVWbJ@hovoldconsulting.com>
Date: Wed, 20 Apr 2022 10:21:14 +0200
From: Johan Hovold <johan@...nel.org>
To: cgel.zte@...il.com
Cc: robh@...nel.org, gregkh@...uxfoundation.org, jirislaby@...nel.org,
linux-serial@...r.kernel.org, linux-kernel@...r.kernel.org,
Minghao Chi <chi.minghao@....com.cn>,
Zeal Robot <zealci@....com.cn>
Subject: Re: [PATCH] tty: serdev: using pm_runtime_resume_and_get instead of
pm_runtime_get_sync
On Mon, Apr 18, 2022 at 11:06:35AM +0000, cgel.zte@...il.com wrote:
> From: Minghao Chi <chi.minghao@....com.cn>
>
> Using pm_runtime_resume_and_get is more appropriate
> for simplifing code
>
> Reported-by: Zeal Robot <zealci@....com.cn>
> Signed-off-by: Minghao Chi <chi.minghao@....com.cn>
> ---
> drivers/tty/serdev/core.c | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/tty/serdev/core.c b/drivers/tty/serdev/core.c
> index 0180e1e4e75d..e550ad3e7f2b 100644
> --- a/drivers/tty/serdev/core.c
> +++ b/drivers/tty/serdev/core.c
> @@ -156,11 +156,9 @@ int serdev_device_open(struct serdev_device *serdev)
> if (ret)
> return ret;
>
> - ret = pm_runtime_get_sync(&ctrl->dev);
> - if (ret < 0) {
> - pm_runtime_put_noidle(&ctrl->dev);
> + ret = pm_runtime_resume_and_get(&ctrl->dev);
> + if (ret < 0)
> goto err_close;
> - }
As the author of this piece of the code, I prefer using the traditional
API consistently rather than mixing in the new helper that uses a
different naming scheme.
No need to change this.
>
> return 0;
Johan
Powered by blists - more mailing lists