[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20220421192449.11004-1-mat.jonczyk@o2.pl>
Date: Thu, 21 Apr 2022 21:24:47 +0200
From: Mateusz Jończyk <mat.jonczyk@...pl>
To: linux-kernel@...r.kernel.org, linux-rtc@...r.kernel.org
Cc: Mateusz Jończyk <mat.jonczyk@...pl>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
Dave Hansen <dave.hansen@...ux.intel.com>, x86@...nel.org,
"H. Peter Anvin" <hpa@...or.com>,
Alessandro Zummo <a.zummo@...ertech.it>,
Alexandre Belloni <alexandre.belloni@...tlin.com>
Subject: [PATCH v2 0/2] x86/rtc: refactoring
Hello,
The first and main patch of this series removes duplicated code in
mach_get_cmos_time() in arch/x86/kernel/rtc.c . This function performed
the same thing as mc146818_get_time() - reading the time from the CMOS
RTC - but used a different algorithm. So modify it to use standard
mc146818_get_time().
The second patch renames a function in arch/x86/kernel/rtc.c.
Greetings,
Mateusz
v2:
- drop the previously first patch ("rtc-mc146818-lib: reduce RTC_UIP
polling period"). Its intent was to make behaviour of
mc146818_get_time() more similar to the existing version of
mach_get_cmos_time() by decreasing the polling period in
mc146818_get_time(). However, I determined that this does not matter
for users of mach_get_cmos_time().
- use pr_err instead of pr_err_ratelimited in the first remaining
patch,
- small patch description modifications.
Tested on 3 computers, and on i386 and amd64 VMs.
Signed-off-by: Mateusz Jończyk <mat.jonczyk@...pl>
Cc: Thomas Gleixner <tglx@...utronix.de>
Cc: Ingo Molnar <mingo@...hat.com>
Cc: Borislav Petkov <bp@...en8.de>
Cc: Dave Hansen <dave.hansen@...ux.intel.com>
Cc: x86@...nel.org
Cc: "H. Peter Anvin" <hpa@...or.com>
Cc: Alessandro Zummo <a.zummo@...ertech.it>
Cc: Alexandre Belloni <alexandre.belloni@...tlin.com>
Mateusz Jończyk (2):
x86/rtc: rewrite mach_get_cmos_time to delete duplicated code
x86/rtc: rename mach_set_rtc_mmss
arch/x86/include/asm/mc146818rtc.h | 2 +-
arch/x86/kernel/rtc.c | 63 +++++-------------------------
arch/x86/kernel/x86_init.c | 2 +-
3 files changed, 11 insertions(+), 56 deletions(-)
base-commit: b2d229d4ddb17db541098b83524d901257e93845
--
2.25.1
Powered by blists - more mailing lists