[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220421083811.GA4105@techsingularity.net>
Date: Thu, 21 Apr 2022 09:38:11 +0100
From: Mel Gorman <mgorman@...hsingularity.net>
To: Matthew Wilcox <willy@...radead.org>
Cc: Nicolas Saenz Julienne <nsaenzju@...hat.com>,
Marcelo Tosatti <mtosatti@...hat.com>,
Vlastimil Babka <vbabka@...e.cz>,
Michal Hocko <mhocko@...nel.org>,
LKML <linux-kernel@...r.kernel.org>,
Linux-MM <linux-mm@...ck.org>
Subject: Re: [PATCH 1/6] mm/page_alloc: Add page->buddy_list and
page->pcp_list
On Wed, Apr 20, 2022 at 09:43:05PM +0100, Matthew Wilcox wrote:
> On Wed, Apr 20, 2022 at 10:59:01AM +0100, Mel Gorman wrote:
> > The page allocator uses page->lru for storing pages on either buddy or
> > PCP lists. Create page->buddy_list and page->pcp_list as a union with
> > page->lru. This is simply to clarify what type of list a page is on
> > in the page allocator.
>
> Hi Mel,
>
> No objection to this change, and I certainly don't want to hold up
> fixing this (or any other) problem in the page allocator.
Minimally, I think the patch makes it easier to implement your suggestion
and it can happen before or after the rest of the series.
> I would
> like to talk about splitting out free page management from struct page.
> Maybe you'd like to discuss that in person at LSFMM, but a quick
> sketch of a data structure might look like ...
>
Unfortunately, I am unable to attend LSF/MM (or any other conference)
physically but I have no objection to splitting this out as a separate
structure. I assume the basis for the change would be for type checking.
> struct free_mem {
> unsigned long __page_flags;
page->flags, ok
> union {
> struct list_head buddy_list;
> struct list_head pcp_list;
> };
page->lru, ok
> unsigned long __rsvd4;
page->mapping, we need that
> unsigned long pcp_migratetype_and_order;
page->index, ok but more on this later
> unsigned long buddy_order;
page->private, ok.
> unsigned int __page_type;
page->_mapcount, we need that too.
> atomic_t _refcount;
page->_refcount, ok.
> };
>
> Am I missing anything there?
>
s/__page_flags/flags/ The allocator checks and modifies these bits so
it has awareness of page->flags
s/__rsvd4/mapping/ The mapping is checked for debugging and the
allocator is responsible for clearing page->mapping
s/pcp_migratetype_and_order/pcp_migratetype/
Commit 8b10b465d0e1 ("mm/page_alloc: free pages in a single pass
during bulk free") removed the migratetype and order stuffing
in page->index. The order is inferred from the array index via
order_to_pindex and pindex_to_order but migratetype is still
stored in page->index by set_pcppage_migratetype
s/__page_type/_mapcount/ because _mapcount if checked for debugging
memcg_data needs to be accessible for debugging checks
_last_cpupid needs to be accessible as it's reset during prepare via
page_cpupid_reset_last. Rather than putting in a dummy field
for virtual, maybe virtual can move.
> (Would you like to use separate types for pcp and buddy? That might be
> overkill, or it might help keep the different stages of "free" memory
> separate from each other)
I think it's overkill because there is too much overlap between a PCP
page and buddy page due to page checks and preparation. The distinguishing
factor between a free pcp page and free buddy page is the PageBuddy bit.
--
Mel Gorman
SUSE Labs
Powered by blists - more mailing lists