[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <7b62c83b-e284-ce43-a229-2b7774edaf95@wanadoo.fr>
Date: Mon, 25 Apr 2022 21:09:44 +0200
From: Christophe JAILLET <christophe.jaillet@...adoo.fr>
To: Vitaly Kuznetsov <vkuznets@...hat.com>, kvm@...r.kernel.org,
Paolo Bonzini <pbonzini@...hat.com>
Cc: Sean Christopherson <seanjc@...gle.com>,
Wanpeng Li <wanpengli@...cent.com>,
Jim Mattson <jmattson@...gle.com>,
Michael Kelley <mikelley@...rosoft.com>,
Siddharth Chandrasekaran <sidcha@...zon.de>,
linux-hyperv@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH v3 07/34] x86/hyperv: Introduce
HV_MAX_SPARSE_VCPU_BANKS/HV_VCPUS_PER_SPARSE_BANK constants
Hi,
Le 14/04/2022 à 15:19, Vitaly Kuznetsov a écrit :
> It may not come clear from where the magical '64' value used in
> __cpumask_to_vpset() come from. Moreover, '64' means both the maximum
> sparse bank number as well as the number of vCPUs per bank. Add defines
> to make things clear. These defines are also going to be used by KVM.
>
> No functional change.
>
> Signed-off-by: Vitaly Kuznetsov <vkuznets@...hat.com>
> ---
> include/asm-generic/hyperv-tlfs.h | 5 +++++
> include/asm-generic/mshyperv.h | 11 ++++++-----
> 2 files changed, 11 insertions(+), 5 deletions(-)
>
> diff --git a/include/asm-generic/hyperv-tlfs.h b/include/asm-generic/hyperv-tlfs.h
> index fdce7a4cfc6f..020ca9bdbb79 100644
> --- a/include/asm-generic/hyperv-tlfs.h
> +++ b/include/asm-generic/hyperv-tlfs.h
> @@ -399,6 +399,11 @@ struct hv_vpset {
> u64 bank_contents[];
> } __packed;
>
> +/* The maximum number of sparse vCPU banks which can be encoded by 'struct hv_vpset' */
> +#define HV_MAX_SPARSE_VCPU_BANKS (64)
> +/* The number of vCPUs in one sparse bank */
> +#define HV_VCPUS_PER_SPARSE_BANK (64)
> +
> /* HvCallSendSyntheticClusterIpi hypercall */
> struct hv_send_ipi {
> u32 vector;
> diff --git a/include/asm-generic/mshyperv.h b/include/asm-generic/mshyperv.h
> index c08758b6b364..0abe91df1ef6 100644
> --- a/include/asm-generic/mshyperv.h
> +++ b/include/asm-generic/mshyperv.h
> @@ -214,9 +214,10 @@ static inline int __cpumask_to_vpset(struct hv_vpset *vpset,
> {
> int cpu, vcpu, vcpu_bank, vcpu_offset, nr_bank = 1;
> int this_cpu = smp_processor_id();
> + int max_vcpu_bank = hv_max_vp_index / HV_VCPUS_PER_SPARSE_BANK;
>
> - /* valid_bank_mask can represent up to 64 banks */
> - if (hv_max_vp_index / 64 >= 64)
> + /* vpset.valid_bank_mask can represent up to HV_MAX_SPARSE_VCPU_BANKS banks */
> + if (max_vcpu_bank >= HV_MAX_SPARSE_VCPU_BANKS)
> return 0;
>
> /*
> @@ -224,7 +225,7 @@ static inline int __cpumask_to_vpset(struct hv_vpset *vpset,
> * structs are not cleared between calls, we risk flushing unneeded
> * vCPUs otherwise.
> */
> - for (vcpu_bank = 0; vcpu_bank <= hv_max_vp_index / 64; vcpu_bank++)
> + for (vcpu_bank = 0; vcpu_bank <= max_vcpu_bank; vcpu_bank++)
> vpset->bank_contents[vcpu_bank] = 0;
>
> /*
> @@ -236,8 +237,8 @@ static inline int __cpumask_to_vpset(struct hv_vpset *vpset,
> vcpu = hv_cpu_number_to_vp_number(cpu);
> if (vcpu == VP_INVAL)
> return -1;
> - vcpu_bank = vcpu / 64;
> - vcpu_offset = vcpu % 64;
> + vcpu_bank = vcpu / HV_VCPUS_PER_SPARSE_BANK;
> + vcpu_offset = vcpu % HV_VCPUS_PER_SPARSE_BANK;
> __set_bit(vcpu_offset, (unsigned long *)
> &vpset->bank_contents[vcpu_bank]);
Here, we could also use directly:
__set_bit(vcpu, vpset->bank_contents);
This is simpler, more readable (IMHO) and also makes 'vcpu_offset' useless.
And in case gcc is not able to optimize it by itself, this should also
save a few cycles.
Just my 2c,
CJ
> if (vcpu_bank >= nr_bank)
Powered by blists - more mailing lists