[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <774dee52-7f68-9d50-4a61-feaedd99eb86@redhat.com>
Date: Sat, 30 Apr 2022 07:54:57 -0700
From: Tom Rix <trix@...hat.com>
To: Xu Yilun <yilun.xu@...el.com>
Cc: Tianfei Zhang <tianfei.zhang@...el.com>, hao.wu@...el.com,
mdf@...nel.org, linux-fpga@...r.kernel.org,
gregkh@...uxfoundation.org, linux-kernel@...r.kernel.org,
Matthew Gerlach <matthew.gerlach@...ux.intel.com>
Subject: Re: [PATCH v3] uio: dfl: add HSSI subsystem feature id
On 4/30/22 7:24 AM, Xu Yilun wrote:
> On Fri, Apr 29, 2022 at 05:23:53AM -0700, Tom Rix wrote:
>> On 4/28/22 5:57 PM, Tianfei Zhang wrote:
>>> From: Matthew Gerlach <matthew.gerlach@...ux.intel.com>
>>>
>>> Add the Device Feature List (DFL) feature id for the
>>> High Speed Serial Interface (HSSI) Subsystem to the
>>> table of ids supported by the uio_dfl driver.
>>>
>>> The HSSI Subsystem is a configurable set of IP blocks
>>> to be used as part of a Ethernet or PCS/FEC/PMA pipeline.
>>> Like the Ethernet group used by the N3000 card, the HSSI
>>> Subsystem does not fully implement a network device from
>>> a Linux netdev perspective and is controlled and monitored
>>> from user space software via the uio interface.
>> Generally you should include the url for the dfl definitions.
>>
>> Can you add it here to the commit log ?
> Do you refer to this url, https://github.com/OPAE/dfl-feature-id ?
Yes, exactly.
To someone not working the day-to-day working dfl they will have no clue
where the fids come from.
When a new one is added to the kernel, it should have a listing in
dfl-feature-id repo.
If it doesn't, there will be a future conflict.
Tom
>
> Hao has some comments about this at
>
> https://lore.kernel.org/all/DM6PR11MB38190E6EEF6DE3EB900290C585F39@DM6PR11MB3819.namprd11.prod.outlook.com/
>
>> Otherwise fine.
>>
>> Reviewed-by: Tom Rix <trix@...hat.com>
>>
>>> Signed-off-by: Matthew Gerlach <matthew.gerlach@...ux.intel.com>
>>> Signed-off-by: Tianfei Zhang <tianfei.zhang@...el.com>
> This patch is now good to me.
>
> Acked-by: Xu Yilun <yilun.xu@...el.com>
>
>>> ---
>>> v3: change the name of this feature id to HSSI_SUBSYS and rewrite
>>> the git message.
>>> v2: add HSSI introduction and the git repo of Feature ID table.
>>> ---
>>> drivers/uio/uio_dfl.c | 2 ++
>>> 1 file changed, 2 insertions(+)
>>>
>>> diff --git a/drivers/uio/uio_dfl.c b/drivers/uio/uio_dfl.c
>>> index 89c0fc7b0cbc..8f39cc8bb034 100644
>>> --- a/drivers/uio/uio_dfl.c
>>> +++ b/drivers/uio/uio_dfl.c
>>> @@ -45,9 +45,11 @@ static int uio_dfl_probe(struct dfl_device *ddev)
>>> }
>>> #define FME_FEATURE_ID_ETH_GROUP 0x10
>>> +#define FME_FEATURE_ID_HSSI_SUBSYS 0x15
>>> static const struct dfl_device_id uio_dfl_ids[] = {
>>> { FME_ID, FME_FEATURE_ID_ETH_GROUP },
>>> + { FME_ID, FME_FEATURE_ID_HSSI_SUBSYS },
>>> { }
>>> };
>>> MODULE_DEVICE_TABLE(dfl, uio_dfl_ids);
Powered by blists - more mailing lists