lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 11 May 2022 18:04:11 +0200
From:   Hans de Goede <hdegoede@...hat.com>
To:     cgel.zte@...il.com, andy.shevchenko@...il.com
Cc:     chi.minghao@....com.cn, coproscefalo@...il.com,
        linux-kernel@...r.kernel.org, markgross@...nel.org,
        platform-driver-x86@...r.kernel.org, zealci@....com.cn
Subject: Re: [PATCH V2] toshiba_acpi: use kobj_to_dev()

Hi,

On 5/11/22 04:16, cgel.zte@...il.com wrote:
> From: Minghao Chi <chi.minghao@....com.cn>
> 
> Use kobj_to_dev() instead of open-coding it.
> 
> Signed-off-by: Minghao Chi <chi.minghao@....com.cn>

Thank you for your patch, I've applied this patch to my review-hans 
branch:
https://git.kernel.org/pub/scm/linux/kernel/git/pdx86/platform-drivers-x86.git/log/?h=review-hans

Note it will show up in my review-hans branch once I've pushed my
local branch there, which might take a while.

Once I've run some tests on this branch the patches there will be
added to the platform-drivers-x86/for-next branch and eventually
will be included in the pdx86 pull-request to Linus for the next
merge-window.

Regards,

Hans



> ---
> v1->v2:
> 	remove Reported-by: Zeal Robot <zealci@....com.cn>
> 
>  drivers/platform/x86/toshiba_acpi.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/platform/x86/toshiba_acpi.c
> b/drivers/platform/x86/toshiba_acpi.c
> index f113dec98e21..0fc9e8b8827b 100644
> --- a/drivers/platform/x86/toshiba_acpi.c
> +++ b/drivers/platform/x86/toshiba_acpi.c
> @@ -2353,7 +2353,7 @@ static struct attribute *toshiba_attributes[] = {
>  static umode_t toshiba_sysfs_is_visible(struct kobject *kobj,
>  					struct attribute *attr, int idx)
>  {
> -	struct device *dev = container_of(kobj, struct device, kobj);
> +	struct device *dev = kobj_to_dev(kobj);
>  	struct toshiba_acpi_dev *drv = dev_get_drvdata(dev);
>  	bool exists = true;
>  

Powered by blists - more mailing lists