[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <3dc832f47406c835ccdb0076edad58c180881134.camel@mediatek.com>
Date: Wed, 11 May 2022 13:29:38 +0800
From: Johnson Wang <johnson.wang@...iatek.com>
To: Chanwoo Choi <cwchoi00@...il.com>, <linux-pm@...r.kernel.org>,
<linux-kernel@...r.kernel.org>
CC: <mka@...omium.org>, <wenst@...omium.org>,
<jia-wei.chang@...iatek.com>, <andrew-sh.cheng@...iatek.com>,
<hsinyi@...omium.org>, <saravanak@...gle.com>,
<cw00.choi@...sung.com>, <myungjoo.ham@...sung.com>,
<kyungmin.park@...sung.com>
Subject: Re: [PATCH v3 0/4] PM / devfreq: Add cpu based scaling support to
passive governor
On Mon, 2022-05-09 at 21:03 +0900, Chanwoo Choi wrote:
> The devfreq passive governor has already supported the devfreq parent
> device
> for coupling the frequency change if some hardware have the
> constraints
> such as power sharing and so on.
>
> Add cpu based scaling support to passive governor with required-opp
> property.
> It uses the cpufreq notifier to catch the frequency change timing of
> cpufreq
> and get the next frequency according to new cpu frequency by using
> required-opp
> property. It is based on patch[1] and then just code clean-up by
> myself.
>
> Make the common code for both passive_devfreq and passive_cpufreq
> parent type to remove the duplicate code.
>
> [1] [RFC,v2] PM / devfreq: Add cpu based scaling support to
> passive_governor
> - https://lore.kernel.org/patchwork/patch/1101049/
>
> Changes from v2:
> :
> https://urldefense.com/v3/__https://patchwork.kernel.org/project/linux-pm/cover/20220507150145.531864-1-cw00.choi@samsung.com/__;!!CTRNKA9wMg0ARbw!x-hPdV1M41ovWuBCw3cVvayFBaqFZRCtLLqDHeX_iNnzvwmOKQYOVQeD9mBfi7n8okEj$
>
> - Drop the following patch ("PM / devfreq: passive: Update frequency
> when start governor")
> - Move p_data->this initialization into
> cpufreq_passive_regiser_notifier()
>
> Changes from v1:
> :
> https://urldefense.com/v3/__https://patchwork.kernel.org/project/linux-pm/cover/20210617060546.26933-1-cw00.choi@samsung.com/__;!!CTRNKA9wMg0ARbw!x-hPdV1M41ovWuBCw3cVvayFBaqFZRCtLLqDHeX_iNnzvwmOKQYOVQeD9mBfiw3rUNcX$
>
> - Rename cpu_data variable to parent_cpu_data to avoid build fail
> - Use for_each_possible_cpu macro when register cpufreq transition
> notifier
> - Add missing exception handling when
> cpufreq_passive_register_notifier is failed
> - Keep cpufreq_policy for posible cpus instead of NR_CPU in order to
> avoid
> the memory waste when NR_CPU is too high.
> - Add reviewed-by tag of Matthias Kaehlcke for patch1
>
>
> Chanwoo Choi (3):
> PM / devfreq: Export devfreq_get_freq_range symbol within devfreq
> PM / devfreq: passive: Reduce duplicate code when passive_devfreq
> case
> PM / devfreq: passive: Keep cpufreq_policy for possible cpus
>
> Saravana Kannan (1):
> PM / devfreq: Add cpu based scaling support to passive governor
>
> drivers/devfreq/devfreq.c | 20 +-
> drivers/devfreq/governor.h | 27 ++
> drivers/devfreq/governor_passive.c | 400 ++++++++++++++++++++++++---
> --
> include/linux/devfreq.h | 17 +-
> 4 files changed, 387 insertions(+), 77 deletions(-)
>
For this serie:
Tested-by: Johnson Wang <johnson.wang@...iatek.com>
BRs,
Johnson Wang
Powered by blists - more mailing lists