lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <87bkw2vgh1.ffs@tglx>
Date:   Thu, 12 May 2022 18:54:50 +0200
From:   Thomas Gleixner <tglx@...utronix.de>
To:     David Hildenbrand <david@...hat.com>,
        Adrian-Ken Rueegsegger <ken@...elabs.ch>,
        dave.hansen@...ux.intel.com, osalvador@...e.de
Cc:     luto@...nel.org, peterz@...radead.org, mingo@...hat.com,
        bp@...en8.de, hpa@...or.com, x86@...nel.org,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] x86/mm: Fix marking of unused sub-pmd ranges

On Thu, May 12 2022 at 11:04, David Hildenbrand wrote:
> On 09.05.22 11:06, Adrian-Ken Rueegsegger wrote:
>>  static void __meminit vmemmap_use_new_sub_pmd(unsigned long start, unsigned long end)
>>  {
>> +	const unsigned long page = ALIGN_DOWN(start, PMD_SIZE);
>> +
>>  	vmemmap_flush_unused_pmd();
>>  
>>  	/*
>> @@ -914,8 +916,7 @@ static void __meminit vmemmap_use_new_sub_pmd(unsigned long start, unsigned long
>>  	 * Mark with PAGE_UNUSED the unused parts of the new memmap range
>>  	 */
>>  	if (!IS_ALIGNED(start, PMD_SIZE))
>> -		memset((void *)start, PAGE_UNUSED,
>> -			start - ALIGN_DOWN(start, PMD_SIZE));
>> +		memset((void *)page, PAGE_UNUSED, start - page);
>>  
>>  	/*
>>  	 * We want to avoid memset(PAGE_UNUSED) when populating the vmemmap of
>
> As the x86 code was based on my s390x code, I assume that this was
> accidentally introduced in the x86 variant.
>
> We'd be marking the wrong range PAGE_UNUSED.
>
> Your fix looks correct to me:
>
> Reviewed-by: David Hildenbrand <david@...hat.com>
>
> Do we want to cc stable?

Yes, we'll add it when picking it up.

I really have to ask why this duplicated code exists in the first
place. There is zero architecture specific code neither in the s390 nor
in the x86 version.

The x86 version is just copy & pasta & fatfinger, if I'm not missing
something here.

Thanks,

        tglx

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ