[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220520122217.30716-1-allen-kh.cheng@mediatek.com>
Date: Fri, 20 May 2022 20:22:14 +0800
From: Allen-KH Cheng <allen-kh.cheng@...iatek.com>
To: Matthias Brugger <matthias.bgg@...il.com>,
Rob Herring <robh+dt@...nel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski@...onical.com>
CC: <Project_Global_Chrome_Upstream_Group@...iatek.com>,
<devicetree@...r.kernel.org>,
<linux-arm-kernel@...ts.infradead.org>,
<linux-kernel@...r.kernel.org>,
<linux-mediatek@...ts.infradead.org>,
"Chen-Yu Tsai" <wenst@...omium.org>,
Ryder Lee <ryder.lee@...nel.org>, <hsinyi@...omium.org>,
Allen-KH Cheng <allen-kh.cheng@...iatek.com>
Subject: [PATCH v11 0/3] Add basic node support for MediaTek MT8186 SoC
MT8186 is a SoC based on 64bit ARMv8 architecture.
It contains 6 CA55 and 2 CA76 cores.
MT8186 share many HW IP with MT65xx series.
This patchset was tested on MT8186 evaluation board to shell.
Based on next-20220519, linux-next/master
changes since v9:
- remove some merged PATCHs from series
- reorder nodes in dts (cpu-map)
- remove okay status in auxadc
- remove unnecessary suffix node name for i2c
- add pwm node
- add dsi-phy node
- add dpi node
changes since v9:
- add one space before equal sign of drive-strength-adv
- corect compatible name for big cores (ca76)
- use upper case of address in pinctrl
- add pwrap node
- add pwm node
changes since v8:
- change name from pins_bus to pins-sda-scl
- correct email address
- add capacity-dmips-mhz for each CPU
- add ppi-partitions in gic node
- change name to power-domain
- remove status "okay" in scp node
- update timer and pericfg compatible in series
changes since v7:
- add scp&auxadc node
changes since v6:
- remove unnecessary blank line
changes since v5:
- replace Mediatek a to MediaTek
- use GPL-2.0-only OR BSD-2-Clause
changes since v4:
- correct driver clock of mt8186
- add power domains controller and clock controllers
- add pinctrl, usb host, spi and i2c nodes
- add node status in mt8186-evb.dts
- correct some dtbs_check warnings
changes since v3:
- remove serial, mmc and phy patch from series. (already merged)
- remove mcusysoff node
- move oscillator nodes at the head of dts
- change name from usb-phy to t-phy
changes since v2:
- add soc {} in mt8186.dtsi
changes since v1:
- add dt-bindings: arm: Add compatible for MediaTek MT8186
Allen-KH Cheng (3):
dt-bindings: arm: mediatek: Add mt8186 pericfg compatible
dt-bindings: arm: Add compatible for MediaTek MT8186
arm64: dts: Add MediaTek SoC MT8186 dts and evaluation board and
Makefile
.../devicetree/bindings/arm/mediatek.yaml | 4 +
.../arm/mediatek/mediatek,pericfg.yaml | 1 +
arch/arm64/boot/dts/mediatek/Makefile | 1 +
arch/arm64/boot/dts/mediatek/mt8186-evb.dts | 232 ++++
arch/arm64/boot/dts/mediatek/mt8186.dtsi | 1016 +++++++++++++++++
5 files changed, 1254 insertions(+)
create mode 100644 arch/arm64/boot/dts/mediatek/mt8186-evb.dts
create mode 100644 arch/arm64/boot/dts/mediatek/mt8186.dtsi
--
2.18.0
Powered by blists - more mailing lists