[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e79a98afda1920a3f8fadd13dc6a20ef2719eeb2.camel@redhat.com>
Date: Sun, 22 May 2022 13:21:41 +0300
From: Maxim Levitsky <mlevitsk@...hat.com>
To: Sean Christopherson <seanjc@...gle.com>
Cc: kvm@...r.kernel.org, Wanpeng Li <wanpengli@...cent.com>,
Vitaly Kuznetsov <vkuznets@...hat.com>,
Jani Nikula <jani.nikula@...ux.intel.com>,
Paolo Bonzini <pbonzini@...hat.com>,
Tvrtko Ursulin <tvrtko.ursulin@...ux.intel.com>,
Rodrigo Vivi <rodrigo.vivi@...el.com>,
Zhenyu Wang <zhenyuw@...ux.intel.com>,
Joonas Lahtinen <joonas.lahtinen@...ux.intel.com>,
Tom Lendacky <thomas.lendacky@....com>,
Ingo Molnar <mingo@...hat.com>,
David Airlie <airlied@...ux.ie>,
Thomas Gleixner <tglx@...utronix.de>,
Dave Hansen <dave.hansen@...ux.intel.com>, x86@...nel.org,
intel-gfx@...ts.freedesktop.org, Daniel Vetter <daniel@...ll.ch>,
Borislav Petkov <bp@...en8.de>, Joerg Roedel <joro@...tes.org>,
linux-kernel@...r.kernel.org, Jim Mattson <jmattson@...gle.com>,
Zhi Wang <zhi.a.wang@...el.com>,
Brijesh Singh <brijesh.singh@....com>,
"H. Peter Anvin" <hpa@...or.com>,
intel-gvt-dev@...ts.freedesktop.org,
dri-devel@...ts.freedesktop.org
Subject: Re: [RFC PATCH v3 04/19] KVM: x86: mmu: allow to enable write
tracking externally
On Thu, 2022-05-19 at 16:27 +0000, Sean Christopherson wrote:
> On Wed, Apr 27, 2022, Maxim Levitsky wrote:
> > This will be used to enable write tracking from nested AVIC code
> > and can also be used to enable write tracking in GVT-g module
> > when it actually uses it as opposed to always enabling it,
> > when the module is compiled in the kernel.
>
> Wrap at ~75.
Well, the checkpatch.pl didn't complain, so I didn't notice.
>
> > No functional change intended.
> >
> > Signed-off-by: Maxim Levitsky <mlevitsk@...hat.com>
> > ---
> > arch/x86/include/asm/kvm_host.h | 2 +-
> > arch/x86/include/asm/kvm_page_track.h | 1 +
> > arch/x86/kvm/mmu.h | 8 +++++---
> > arch/x86/kvm/mmu/mmu.c | 17 ++++++++++-------
> > arch/x86/kvm/mmu/page_track.c | 10 ++++++++--
> > 5 files changed, 25 insertions(+), 13 deletions(-)
> >
> > diff --git a/arch/x86/include/asm/kvm_host.h b/arch/x86/include/asm/kvm_host.h
> > index 636df87542555..fc7df778a3d71 100644
> > --- a/arch/x86/include/asm/kvm_host.h
> > +++ b/arch/x86/include/asm/kvm_host.h
> > @@ -1254,7 +1254,7 @@ struct kvm_arch {
> > * is used as one input when determining whether certain memslot
> > * related allocations are necessary.
> > */
>
> The above comment needs to be rewritten.
Good catch, thank a lot!!
>
> > - bool shadow_root_allocated;
> > + bool mmu_page_tracking_enabled;
> > #if IS_ENABLED(CONFIG_HYPERV)
> > hpa_t hv_root_tdp;
> > diff --git a/arch/x86/include/asm/kvm_page_track.h b/arch/x86/include/asm/kvm_page_track.h
> > index eb186bc57f6a9..955a5ae07b10e 100644
> > --- a/arch/x86/include/asm/kvm_page_track.h
> > +++ b/arch/x86/include/asm/kvm_page_track.h
> > @@ -50,6 +50,7 @@ int kvm_page_track_init(struct kvm *kvm);
> > void kvm_page_track_cleanup(struct kvm *kvm);
> >
> > bool kvm_page_track_write_tracking_enabled(struct kvm *kvm);
> > +int kvm_page_track_write_tracking_enable(struct kvm *kvm);
> > int kvm_page_track_write_tracking_alloc(struct kvm_memory_slot *slot);
> >
> > void kvm_page_track_free_memslot(struct kvm_memory_slot *slot);
> > diff --git a/arch/x86/kvm/mmu.h b/arch/x86/kvm/mmu.h
> > index 671cfeccf04e9..44d15551f7156 100644
> > --- a/arch/x86/kvm/mmu.h
> > +++ b/arch/x86/kvm/mmu.h
> > @@ -269,7 +269,7 @@ int kvm_arch_write_log_dirty(struct kvm_vcpu *vcpu);
> > int kvm_mmu_post_init_vm(struct kvm *kvm);
> > void kvm_mmu_pre_destroy_vm(struct kvm *kvm);
> >
> > -static inline bool kvm_shadow_root_allocated(struct kvm *kvm)
> > +static inline bool mmu_page_tracking_enabled(struct kvm *kvm)
> > {
> > /*
> > * Read shadow_root_allocated before related pointers. Hence, threads
> > @@ -277,9 +277,11 @@ static inline bool kvm_shadow_root_allocated(struct kvm *kvm)
> > * see the pointers. Pairs with smp_store_release in
> > * mmu_first_shadow_root_alloc.
> > */
>
> This comment also needs to be rewritten.
Also thanks a lot, next time I'll check comments better.
>
> > - return smp_load_acquire(&kvm->arch.shadow_root_allocated);
> > + return smp_load_acquire(&kvm->arch.mmu_page_tracking_enabled);
> > }
>
> ...
>
> > diff --git a/arch/x86/kvm/mmu/page_track.c b/arch/x86/kvm/mmu/page_track.c
> > index 2e09d1b6249f3..8857d629036d7 100644
> > --- a/arch/x86/kvm/mmu/page_track.c
> > +++ b/arch/x86/kvm/mmu/page_track.c
> > @@ -21,10 +21,16 @@
> >
> > bool kvm_page_track_write_tracking_enabled(struct kvm *kvm)
>
> This can be static, it's now used only by page_track.c.
I'll fix this.
>
> > {
> > - return IS_ENABLED(CONFIG_KVM_EXTERNAL_WRITE_TRACKING) ||
> > - !tdp_enabled || kvm_shadow_root_allocated(kvm);
> > + return mmu_page_tracking_enabled(kvm);
> > }
> >
> > +int kvm_page_track_write_tracking_enable(struct kvm *kvm)
>
> This is too similar to the "enabled" version; "kvm_page_track_enable_write_tracking()"
> would maintain namespacing and be less confusing.
Makes sense, thanks, will do!
>
> Hmm, I'd probably vote to make this a "static inline" in kvm_page_track.h, and
> rename mmu_enable_write_tracking() to kvm_mmu_enable_write_tracking and export.
> Not a strong preference, just feels silly to export a one-liner.
The sole reason I did it this way, because 'page_track.c' this way contains all the interfaces
that an external user of write tracking needs to use.
>
> > +{
> > + return mmu_enable_write_tracking(kvm);
> > +}
> > +EXPORT_SYMBOL_GPL(kvm_page_track_write_tracking_enable);
> > +
> > +
> > void kvm_page_track_free_memslot(struct kvm_memory_slot *slot)
> > {
> > int i;
> > --
> > 2.26.3
> >
Best regards,
Maxim Levitsky
Powered by blists - more mailing lists