[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <2f43382d-3ab1-3562-c527-5cfef9ac069e@redhat.com>
Date: Tue, 24 May 2022 09:46:34 +0800
From: Xiubo Li <xiubli@...hat.com>
To: Luis Chamberlain <mcgrof@...nel.org>
Cc: jlayton@...nel.org, idryomov@...il.com, viro@...iv.linux.org.uk,
willy@...radead.org, vshankar@...hat.com,
ceph-devel@...r.kernel.org, arnd@...db.de,
akpm@...ux-foundation.org, linux-fsdevel@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v5 1/2] fs/dcache: add d_compare() helper support
On 5/24/22 1:57 AM, Luis Chamberlain wrote:
> On Thu, May 19, 2022 at 06:18:45PM +0800, Xiubo Li wrote:
>> Reviewed-by: Jeff Layton <jlayton@...nel.org>
>> Signed-off-by: Xiubo Li <xiubli@...hat.com>
>> ---
>> fs/dcache.c | 15 +++++++++++++++
>> include/linux/dcache.h | 2 ++
>> 2 files changed, 17 insertions(+)
>>
>> diff --git a/fs/dcache.c b/fs/dcache.c
>> index 93f4f5ee07bf..95a72f92a94b 100644
>> --- a/fs/dcache.c
>> +++ b/fs/dcache.c
>> @@ -2262,6 +2262,21 @@ static inline bool d_same_name(const struct dentry *dentry,
>> name) == 0;
>> }
>>
>> +/**
>> + * d_compare - compare dentry name with case-exact name
>> + * @parent: parent dentry
>> + * @dentry: the negative dentry that was passed to the parent's lookup func
>> + * @name: the case-exact name to be associated with the returned dentry
>> + *
>> + * Return: 0 if names are same, or 1
>> + */
>> +bool d_compare(const struct dentry *parent, const struct dentry *dentry,
>> + const struct qstr *name)
>> +{
>> + return !d_same_name(dentry, parent, name);
> What's wrong with d_same_name()? Why introduce a whole new operation
> and export it when you the same prototype except first and second
> argument moved with an even more confusing name?
Sounds resonable, will export the d_same_name instead.
>> +}
>> +EXPORT_SYMBOL(d_compare);
> New symbols should go with EXPORT_SYMBOL_GPL() instead.
Not familiar with the story about this, before I checked the Doc and
didn't find any where says we must use it and just followed what recent
commits did.
If this is what we should use I will switch to it in the next version.
Thanks
-- Xiubo
>
> Luis
>
Powered by blists - more mailing lists